Installed Ghost on Proxmox in a container - install went flawlessly.

Tried to upload a design from https://ghost.org/marketplace/ and got "your upload is too big" every single time.

https://www.santoshsrinivas.com/solving-the-maximum-file-size-error-on-g...

has the solution. Add that one line

client_max_body_size 2m;

to /etc/nginx/nginx.conf and restart nginx. Maybe a future version of TKL Ghost could have this built in already.

Replies (1)

Great suggestion!

Reply 1

Great suggestion and thanks for posting back with the details on how you fixed it!

I've opened a feature request on our issue tracker to include in the next release.