Forum archive
How to move a site to tklapp
Hi,
I've successfully set up a joomla appliance on the hub. I'm familiar with moving my Joomla site around, but when I tried to upload it and setup my site on my tklapp, it returns a 404 error.
Here's the steps I've taken so far:
1. gzip site directory on old server, upload to tklapp and unpack
2. do a mysql dump, create a new database with same user/pass on tklapp, import
3. modify joomla's config file to reflect new folder paths
At this point, I cannot access the Joomla backed. So I tried creating just a "hello world" .html file and put it into the directory. I cannot access that file, it also returns a 404 error.
I think I need to verify that the permissions are set properly. So I tried to look at the working install of Joomla that came with the tklapp. I noticed that the owner of directories and files was www-data, where as mine was "20082"
So I guess my question is, what steps should I take so that a basic .html file is accessible in /var/www/test?
And the TKL Joomla appliance. But having said that, from what you've stated, I agree that it sounds likely that you have a permissions issue. The easiest way to go is make www-data the owner of the whole directory from /var/www up. This can most easily be achieved from the commandline:
And hopefully that should get you going.