Forum archive
[SOLVED] Redirecting to "cp" folder
I am running the live version in a VM. Whenever I browse to the server it redirects to a "cp" folder with a 503 error.
Manually typing in index.html retrieves the page in /var/www.
Version: turnkey-tomcat-apache-12.0-squeeze-x86.iso
Solution:
Change /etc/tomcat6/mod_jk.conf from:
RedirectMatch ^/$ /cp
to
RedirectMatch ^/$ /index.html
Link: /docs/tomcat-apache
There are over 100 different appliances...
But I see from your second screenshot that it is the Tomcat on Apache appliance.
So I have a couple of thoughts. Firstly, to serve html this appliance needs some tweaking. Have a look at the links here (the Tomcat on Apache Wiki entry).
Secondly Tomcat like lots of RAM, I suspect that thre reasoon why you are getting a 503 rather than the example Tomcat app ('cp') is because you have insufficient RAM allocated, or perhaps it just doesn't like running live? I would install it to a VM and make sure you give it at least 1GB RAM.