Forum archive
Ugh. MySQL stopped, have no idea what to do
Hey guys,
Hoping someone here has some ideas, as I've searched and tried several things and have come up short.
Someone told me a website I run was down and went to check it out. "Error establishing database connection".
Logged into webmin to discover this little gem of a message:
"MySQL is not running on your system - database list could not be retrieved.
Click this button to start the MySQL database server on your system with the command /etc/init.d/mysql start >/dev/null 2>&1 &. This Webmin module cannot administer the database until it is started."
Next to it was a button that says "Start MySQL Server" which does nothing but re-load the page when clicked. I also tried starting it through commands on webshell, only to get an error message that says "Job failed to start."
Also, when I type "mysql" in the shell, I get this:
"ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)"
Finally, I checked my error logs out. A few new clues that lead nowhere:
121105 22:05:18 [Note] Plugin 'FEDERATED' is disabled. 121105 22:05:18 InnoDB: Initializing buffer pool, size = 8.0M 121105 22:05:18 InnoDB: Completed initialization of buffer pool 121105 22:05:18 InnoDB: Started; log sequence number 0 44253 121105 22:05:18 InnoDB: Starting shutdown... 121105 22:05:24 InnoDB: Shutdown completed; log sequence number 0 44253 121105 22:05:24 [Note] Plugin 'FEDERATED' is disabled. 121105 22:05:24 InnoDB: Initializing buffer pool, size = 8.0M 121105 22:05:24 InnoDB: Completed initialization of buffer pool 121105 22:05:24 InnoDB: Started; log sequence number 0 44253 ERROR: 1050 Table 'plugin' already exists 121105 22:05:24 [ERROR] Aborting 121105 22:05:24 InnoDB: Starting shutdown... 121105 22:05:34 InnoDB: Shutdown completed; log sequence number 0 44253 121105 22:05:34 [Note] /usr/sbin/mysqld: Shutdown complete 121105 22:05:35 [Note] Plugin 'FEDERATED' is disabled. 121105 22:05:36 InnoDB: Initializing buffer pool, size = 8.0M 121105 22:05:36 InnoDB: Completed initialization of buffer pool 121105 22:05:39 InnoDB: Started; log sequence number 0 44253 121105 22:05:48 [Note] Event Scheduler: Loaded 0 events 121105 22:05:48 [Note] /usr/sbin/mysqld: ready for connections. Version: '5.1.66-0ubuntu0.10.04.1' socket: '/var/run/mysqld/mysqld.sock' port: 3306 (Ubuntu) 121127 0:07:10 [ERROR] /usr/sbin/mysqld: Disk is full writing './wordpress/wp_comments.MYD' (Errcode: 28). Waiting for someone to free space... (Expect up to 60 secs delay for server to continue after freeing disk space) 121127 0:07:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 0:17:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 0:27:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 0:37:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 0:47:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 0:57:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:07:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:17:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:27:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:37:10 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:47:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 1:57:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:07:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:17:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:27:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:37:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:47:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 2:57:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:07:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:17:11 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:27:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:37:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:47:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 3:57:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 4:07:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 4:17:12 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs 121127 4:27:12 [ERROR] /usr/sbin/mysqld: Retry in 60
I wiped out the /wordpress/wp_comments.MYD file clear, nothing happened.
If all else fails, I have an old backup...but I really don't want to use that since this is an e-commerce store and we would lose the last four months worth of sales data, plus blog posts, web copy, etc.
I'm not too familiar with this stuff, so if you have an explanation or steps towards a fix to offer up, please do so in dumbed-down words...I'm not as smart as you Turnkey guys! :)
Thanks,
Tom
It looks like your disk may be full, preventing mysqld from starting. Might want to check that...
You can run 'df -k' to see the disk utiliziation for your filesystems.