Forum archive
ntpd does not start
Just installed the Revision Control appliance as a VM. Everything seems to be working just fine with the exception of ntp. ntpq -p returns "ntpq: read: connection refused". Hmmm.
Is ntpd running? "service ntp status" returns "NTP server is not running ... failed!"
The symlink in /etc/rc2.d is there to ../init.d/ntp. On the console during boot I see an indication that ntpd has (allegedly) been started. However, no joy.
syslog shows
May 15 15:52:42 scs ntpd[1229]: ntpd 4.2.6p2@1.2194-o Sun Oct 17 13:45:13 UTC 2010 (1)
May 15 15:52:42 scs ntpd[1230]: proto: precision = 0.314 usec
May 15 15:52:42 scs ntpd[1230]: unable to bind to wildcard address 0.0.0.0 - another process may be running - EXITING
May 15 15:52:49 scs ntpdate[981]: no server suitable for synchronization found
Huh? Another process may be running? How can that be?
If, when I reboot and first log in, I run 'service ntp start', ntpq -p works fine.
I should note that I installed webmin-time to let me manage things. Could that have screwed something up?
Any ideas?
Hello,
I had this also, using TKL Core 13.0 Wheezy. I am using a TKL Core VM (under Proxmox! :-) ) as an authoritative server for doing DNS, DHCP and NTP (master.)
After getting NTPD all setup and working, I was seeing the same error in my syslog. I noticed back to back was NTPDate executing. Others speak of this as a race condition. The ver of NTPD used on Wheezy is suppose to have it resolved, from what I have read, but maybe I'm misreading?
Here is what I did to fix it-- it seems that the system is stable w/o issues, so I think it's an acceptable solution, but someone please feel free to correct me.
SOLUTION: Remove NTPDate from running at startup. To do this; Disabled NTPDate by renaming /etc/network/if-up.d/ntpdate to ntpdate.ORG
After rebooting, you should see ntpd startup property. If you do ntpq -p, you should see ntpd working. (if all say .INIT. and never change, then there's still a problem.)