Forum archive
tklbam-restore cannot restore databases, mysql connection error
Dear All,
I'm having a problem restoring a redmine-12.1-squeeze-amd64 appliance from the hub to a fresh local VM install - works fine with 11.3 x86 appliances, but no luck with 12.1 thanks to the following error:
"Restoring databases
===================
SKIPPING MYSQL DATABASE RESTORE: mysql error (1): ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)"
myslq, which *had* been running on the local VM before the restore, has been stopped, and there is no sock file. Sounds similar to this post. mysql fails to start manually. myslq .log and .err are emtpy (there are a lot of innodb errors relating to ./ibdata1 in syslog, possibly unrelated).
So tklbam-restore appears to stop mysql before it is able to restore any databases. If I do a tklbam-restore-rollback, then myslql automatically starts up again, sock file is created, and all is as it was before the restore.
Any advice would be very much appreciated.
Regards,
Aaron.
Some extra experiments:
This behaviour does not occur with 11.3 appliances - is this a tklbam-restore bug in 12.1 appliances? tklbam is of limited use if it cannot restore the databases.
If it is not a tklbam bug, then does anyone have any idea why this is occuring?
Aaron.