Forum archive
My System Can't boot up
Hello,
I have been install turnkey linux file server sucessfuly. First I install with 1 hard drive 80Gb capacity. Then I added new hard drive with capacity 4TB. And added to LVM successfuly. After a week, I restarted my turnkey file server but can't boot up with stuck in error:
Gave up waiting for root file system bla bla bla...
ALERT!!! /dev/disk/by-UUID/xxx does not exist
Dropping to a shell
When I try a command blkid then I could not find disk by UUID xxx. They appear just UUID by sda1, sda5 and sdb. sda1, sda5 are my 80gb hard drive and sdb is my 4tb hard drive.
But when I try to boot turnkey linux with live cd, then command blkid found UUID xxx like in alert. with point to /dev/mapper/...
Could you please provide me the exact issue about that?
Perhaps you workaround this issue by adjusting it to just use the /dev/sdXN (e.g. /dev/sda1) identifier (rather than the UID). That shouldn't have any negative consequences as long as you don't add further additional hardware or change where the drives connect.