Forum archive
SMTP issues - unable to connect : CentOS 6.5, Postfix, Dovecot, MySQL
Hi
I'm try to setup an email server on a CentOS system with Postfix, Dovecot and MySQL.
I'm following this article for an Ubuntu system:
https://library.linode.com/email/postfix/postfix2.9.6-dovecot2.0.19-mysql
I can connect to the server using both secure pop/imap but can't with SMTP. I have tried sending an email from root and it remains in the queue. I get the follow error:
connect to osiris.example.com[private/dovecot-lmtp]: No such file or directory
Here's the version that's installed on my system:
MySQL v5.5.36
Postfix v2.6.6
Dovecot v2.0.9
Thank you in advance.
Sophal
It seems this entry only in /etc/postfix/main.cf applies to Ubuntu/Debian systems.
With CentOS systems you'll need to specify the following:
You'll also need add this entry in the /etc/postfix/master.cf file:
dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/libexec/dovecot/deliver -f ${sender} -d ${recipient}