Forum archive
default route not saved when configuring a static IP
Hi,
I am new to this forum and new to TKL.
I have a Dell PowerEdge server r815 that I want to install latest TKL appliance. Previous versions of TKL I used to get an error "No network adapters detected", search around the forum and found this:
/forum/support/20130618/getting-no-network-ad...
That solved my problem and I could install all the appliances I wanted (tried with owncloud, canvas and OTRS)
Now since the new updates on all the appliance I am able to add static IP perfectly :) but after entering the static IP the default gateway always shows empty , rest all the values are there, so I have my server IP, subnet mask and dns nameserver but default gateway remains blank.
Checking inside /etc/network/interfaces shows all the values are there but I am unable to reach the appliance.
Any help is appreciated.
If any other info is required kindly do let me know,
Regards,
I'm not sure if I'm running across the same issue as you but i have just been trying to re-create your issue and can, sort of... (Although on reflection I think it may be something different altogether...)
I have set up a new TKL v13.0 (x64) LAMP instance on my PVE server and gave it 3 different (virtual) NICs. Here is what I found:
I double checked by creating another new VM (the same except with a single NIC) and that works fine. So unfortunately I was not able to confirm whether this is an issue with my hypervisor (Proxmox) or the TKL appliance itself.
Sorry despite my best efforts, I don't think that I am very much help to you on this one...
[update] I just had a brainwave and deleted all 3 vNICs from my test server and readded 2 (but this time used just default PVE settings). It all now works as expected (DHCP works as does setting a static IP). To be extra sure I stopped the VM and added 2 move vNICs (total of 4) and again all is fine (although by default the 4th had to be initialised). Following that I think that we can safely say that the v13.0 ConfConsole works ok with multiple NICs (at least under some circumstance). Considering your other errors I can't help but think that perhaps this is a hardware and/or driver and/or networking issue of some sort...