Forum archive
OpenVPN refused to start
I recently found out that their was an image of Turnkey OpenVPN, so i installed it on a VPS and everything was running fine.
I created a user with the
openvpn-addclient client-name client-email [private-subnet]
That worked well, but i needed to restart the openvpn service, but after that it refuses to start up.
Syslog tells me:
ovpn-server[4063]: Options error: Unrecognized option or missing parameter(s) in /etc/openvpn/server.conf:37: route (2.2.1)
So I checked the server.conf and this is the outcome:
port 1194
proto udp
dev tun
comp-lzo
keepalive 10 120
persist-key
persist-tun
user nobody
group nogroup
chroot /etc/openvpn/easy-rsa/keys/crl.jail
crl-verify crl.pem
ca /etc/openvpn/easy-rsa/keys/ca.crt
dh /etc/openvpn/easy-rsa/keys/dh1024.pem
tls-auth /etc/openvpn/easy-rsa/keys/ta.key 0
key /etc/openvpn/easy-rsa/keys/server.key
cert /etc/openvpn/easy-rsa/keys/server.crt
ifconfig-pool-persist /var/lib/openvpn/server.ipp
client-config-dir /etc/openvpn/server.ccd
status /var/log/openvpn/server.log
verb 4
# virtual subnet unique for openvpn to draw client addresses from
# the server will be configured with x.x.x.1
# important: must not be used on your network
server 10.129.214.0 255.255.255.0
# push routes to clients to allow them to reach private subnets
push "route 10.0.1.0 255.255.255.0"
# subnet behind a client: user1
route
It is the last line which syslog refers to...so i guess i needed to fill in the [private-subnet], but to be honest, i don't know what i need to fill in there.
Is there someone with some network knowledge who can point me to the right direction? I know it is the standard network knowledge i need to know, but i was always bad in this :( so i deeply apologize for this.
After some reading i have added
to the last line. I can connect now, but i have no internet. But if i use an IP it works, so i guess DNS were not properly set, so i set this in server.conf
But that didn't do the trick. So i guess i have misconfigured something. Syslog gives me these errors:
So i don't know how to handle this anymore. Any suggestions?