Forum archive
Upgrading Moodle from 12.1 to 14.0
I am currently in the process of upgrading a moodle installation from 12.1 to 14.0. I have backed up from the original server and installed on the new one.
I have followed through the process, up to the point of creating an admin user. after doing so, I cannot access the site.
The following error appears in Firefox. Internet Explorer and Google Chrome also fail.
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies.
I have attempted to clear the cookies to no effect. i believe this to be a server confguration issue.
If I've got it wrong please correct me.
Assuming that I have you right, in theory you should be able to login straight away (using your old credentials - you shouldn't need to make new ones).
Having said that there are significant changes between v12.0 & v14.0 so you may need to do some tweaking.
A few things come to mind.
Firstly it's probably worth checking if php5-xcache is installed (it was in earlier versions but shouldn't be now):
If it is installed, remove it and restart Apache:Secondly, it might also be useful to check the webserver logs. Often they will give something useful (or at least more useful). You can see the last few lines of the log file like this:
Finally Apache config changed quite a bit between v13.0 & v14.0. Apache have a page on upgrading that you'll probably find useful. IIRC the file you'll need to adjust is /etc/apache2/sites-available/moodle.conf