Forum archive
[SOLVED] pts and proc errors running LXC appliance in virtual machine
Hello,
I've been trying to get the LXC appliance running in a virtual machine, and I'm getting errors when I run the lxc-create script in either KVM or VirtualBox (lxc-create -n wp -t turnkey -- wordpress -i /tmp/inithooks.conf -v 14.1-jessie). I am getting some errors related to /dev/pts and /proc at the end of the creation script console output and the container won't let me attach to it
Does anyone have advice for troubleshooting?
Thanks,
Daryl
... Fetched 12.1 MB in 11s (1090 kB/s) Reading package lists... Reading package lists... Building dependency tree... Reading state information... dpkg is already the newest version. debian-archive-keyring is already the newest version. The following packages were automatically installed and are no longer required: acl libcryptsetup4 libopts25 libuuid-perl linux-base Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded. Reading package lists... Building dependency tree... Reading state information... The following packages will be REMOVED: acl libcryptsetup4 libopts25 libuuid-perl linux-base 0 upgraded, 0 newly installed, 5 to remove and 22 not upgraded. After this operation, 911 kB disk space will be freed. E: Can not write log (Is /dev/pts mounted?) - posix_openpt (2: No such file or directory) (Reading database ... 24844 files and directories currently installed.) Removing acl (2.2.52-2) ... Removing libcryptsetup4:amd64 (2:1.6.6-5) ... Removing libopts25:amd64 (1:5.18.4-3) ... Removing linux-base (3.5) ... Removing libuuid-perl (0.05-1+b1) ... Processing triggers for man-db (2.7.0.2-5) ... Processing triggers for libc-bin (2.19-18+deb8u4) ... Error, do this: mount -t proc proc /proc
I just verified that the signature was okay