Forum archive
Fixing GRUB install
Hi All
I wonder if anyone can help fix a GRUB install on a Wordpress install. I'm not sure if the issue was first made as a result of the original install? Here is the error message:
CRON-APT RUN [/etc/cron-apt/config]: Thu Dec 1 14:30:01 UTC 2022
CRON-APT SLEEP: 1617, Thu Dec 1 14:56:58 UTC 2022
CRON-APT ACTION: 5-install
CRON-APT LINE: /usr/bin/apt-get -o quiet=1 autoclean -y
Reading package lists...
Building dependency tree...
Reading state information...
CRON-APT LINE: /usr/bin/apt-get -o quiet=1 dist-upgrade -y -o APT::Get::Show-Upgraded=true -o Dir::Etc::sourcelist=/etc/apt/sources.list.d/security.sources.list -o Dir::Etc::sourceparts=nonexistent -o DPkg::Options::=--force-confdef -o DPkg::Options::=--force-confold
Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following package was automatically installed and is no longer required:
linux-image-4.19.0-14-amd64
Use 'apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up grub-pc (2.06-3~deb10u2) ...
Installing for i386-pc platform.
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13289: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13289: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13289: grub-install
grub-install: error: unable to identify a filesystem in hostdisk//dev/sda; safety check can't be performed.
Installing for i386-pc platform.
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13307: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13307: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13307: grub-install
Installation finished. No error reported.
Installing for i386-pc platform.
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13323: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13323: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13323: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13323: grub-install
File descriptor 3 (pipe:[9529405]) leaked on vgs invocation. Parent PID 13323: grub-install
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: diskfilter writes are not supported.
You must correct your GRUB install devices before proceeding:
DEBIAN_FRONTEND=dialog dpkg --configure grub-pc
dpkg --configure -a
dpkg: error processing package grub-pc (--configure):
installed grub-pc package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
grub-pc
E: Sub-process /usr/bin/dpkg returned an error code (1)
Thanks all for the great work!
Donald
It seems that there is something not quite right with your grub config so the system can't automatically configure it. So it's trying to force an interactive install. But the auto security updates don't allow that, so the install fails.
Please try manually installing grub:
It will ask where you want to install grub. Assuming that it's a fairly standard install - with only one single "physical" disk (virtualized or otherwise), then you'll want to install grub to '/dev/sda' (note devices with trailing digits are partitions - whilst it won't do any harm, there is no value installing grub there). It should give you options to install to, so just select the appropriate device. Note that under some virtualisation platforms, the device naming may be slightly different (e.g. under Xen the first drive is usually '/dev/xvda' - I think '/dev/vda' is another possibly).
If you want to be 100% sure, please run this command:
On an AWS server, it returns: