Forum archive
TKLBAM restore failed - S3 authentication error
Hi all
We broke our website yesterday, as one of the WP plugins needed a newer PHP version.
We took a back up just before starting the process, and that saved correctly.
However, the backup restore fails with an authentication error. Below is the complete output
root@nginx-php-fastcgi /etc# duplicity --archive-dir=/var/cache/duplicity --s3-unencrypted-connection s3://our_s3_url /tmp/tklbam-NvXy2w
Traceback (most recent call last):
File "/usr/bin/duplicity", line 1405, in <module>
with_tempdir(main)
File "/usr/bin/duplicity", line 1398, in with_tempdir
fn()
File "/usr/bin/duplicity", line 1249, in main
action = commandline.ProcessCommandLine(sys.argv[1:])
File "/usr/lib/python2.7/dist-packages/duplicity/commandline.py", line 1007, in ProcessCommandLine
backup, local_pathname = set_backend(args[0], args[1])
File "/usr/lib/python2.7/dist-packages/duplicity/commandline.py", line 900, in set_backend
globals.backend = backend.get_backend(bend)
File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 158, in get_backend
return _backends[pu.scheme](pu)
File "/usr/lib/python2.7/dist-packages/duplicity/backends/_boto_single.py", line 77, in _init_
self.resetConnection()
File "/usr/lib/python2.7/dist-packages/duplicity/backends/_boto_single.py", line 149, in resetConnection
is_secure=(not globals.s3_unencrypted_connection))
File "/usr/lib/python2.7/dist-packages/boto/s3/connection.py", line 155, in _init_
suppress_consec_slashes=suppress_consec_slashes)
File "/usr/lib/python2.7/dist-packages/boto/connection.py", line 486, in _init_
host, config, self.provider, self._required_auth_capability())
File "/usr/lib/python2.7/dist-packages/boto/auth.py", line 417, in get_auth_handler
'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV1Handler'] Check your credentials
Has anyone come across this issue before?
Many thanks
This was due to us still using debian stretch