Forum archive
LXC template for Wordpress missing
I'm using the LXC appliance on AWS and I'm trying to create a Wordpress container. I follow the instructions but when I issue the command
lxc-create -n wp1 -t turnkey -- wordpress -i /root/inithooks.conf
I get an error.
root@lxc ~# lxc-create -n wp1 -t turnkey -- wordpress -i /root/inithooks.conf
debootstrap is /usr/sbin/debootstrap
FATAL [lxc-turnkey]: turnkey version 14.2-jessie-amd64 is not recognized:
lxc_container: container creation template for wp1 failed
lxc_container: Error creating container wp1
Any help will be appreciated.
That should definitely work, but clearly it doesn't. I just fired up an instance and can definitely reproduce this, so have added it as a bug to our tracker.
As noted there on the issue, it turns out that it was actually my fault (oops), via this commit. I obviously didn't test that properly and it's not quite right. To add insult to injury, it turns out that the reason why I updated that code wasn't even completely legitimate either... :(
Anyway, as noted on the issue, the "proper" workaround is to return that script to it's previous condition via the sed line in the bug report (the line of code starting with "sed", right at the bottom, in the "Workaround" section).
An alternate workaround would be to explicitly state the version as "14.2-jessie" at launch (and forever after), i.e. add "-v 14.2-jessie" to the end of the launch line. Something like this:
FWIW, I just used this and it worked fine (I created wp1.conf first):