Forum archive
Inv Ninja 17.2 after Security updates VM won't boot
Hi Jeremy,
I downloaded and installed the New TurnKey Invoice Ninja version (17.2) ISO on a Proxmox vm. Everything works fine until I do the security updates which updates the kernel from 5.10.0-19 to 5.10.0-20, then everything fails .. It seem that grub cannot find the root fs ... messages below
0.7170071 Call Trace:
0.717218] dump_stack•0x6b/0x83
0.7175101 panic•0x101/0x2d7
0.7177511 mount block root•0x301/0x317 - -
0.7180711 prepare_namespace+0x136/0x165
0.7183661 kernel init freeable•0x256/0x280 - -
0.718617] ? rest init•0xb1/0xb1 -
0.7189031 kernel init•0xa/0x10c -
0.7191531 ret from fork•0x22/0x30 - -
0.7195031 kernel Offset: 0xba00000 from 0xffffffff81000000
e: 0xffffffff80000000-0xffffffffbfffffff)
(relocation ra11g
[ 0.720061] ---[ end kernel panic - not syncing: UFS: Unable to mount root fs
on unknown-block(0,0) ]---
If I escape out of the default grub choice and select 5.10.0-19 manually it boots normally and everything works fine.. see the VM config below ...
I've installed it many times with different scsi emulations ... nothing seems to work ... I'm Stumped ... any ideas?
Hey Jeremy,
You nailed!! .. It never occurred never occurred to me to actually check which kernel was installed ..
Just followed the instructions blindly ?? anyhow she is alive !!!
thx