Forum archive
openstack qcow2 file downloads broken
I noticed this a while back and it's still happening. When attempting to download OpenStack images, I get an error and the download does not work. Example text:
Error: not a legal filename 'turnkey-postgresql-15.0-stretch-amd64-openstack.qcow2'
Unfortunately, it's a known issue since we moved to qcow2 images. I've tried to fix it (and the new regex I've implemented works when tested in a regex tester) but it hasn't fixed it. :( My PHP skills are pretty rudimentary, so I think I need to get someone who knows it better to have a look...
However, in the meantime, you can download them direct from the mirror. Look for the latest v15.x version of each one.
Hopefully can find what you need there. If not, please ask.