Forum archive
WP turnkey linux appliance - SQL administrator login failed : Incorrect administration username or password
Hi guys, I was wondering if you could help as I am quite a beginner with those things! I have the latest WordPress and turnkey linux instal and my My SQL admin password stopped working. I am trying to login from the Webmin interface and I get an error:
The full MySQL error message was : DBI connect failed : Access denied for user 'root'@'localhost' (using password: YES)
I tried changing the password from the Module config on the right by the password doesn't seem to be accepted. I have also stopped and restart the server just to make sure. Nothing seems to work. The problem is that even when I try to login with no password from the console, I get an error:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
So basically I can't even login even if there is no password. I was playing around with the database earlier on before that happens and I suspect I changed something but I am not sure why. I might have actually deleted the root account thinking it was another account I had created eariler. I read somewhere else that possibly I need to assign that account localhost access. If that's the case how could I do that from teh console or webmin?
Thanks guys, I hope you can help I am quite desperate!
To access MySQL, you need to use the MySQL root user password to login. To clarify, that is a completely separate password to your root Linux user (although just for extra confusion, you could use the same password for both accounts if you wanted to).
Your MySQL root account definitely requires a password, AFAIK it's not possible to have a MySQL root user without a password (and if it is, it probably shouldn't be). So that explains why trying to log into MySQL from the commandline wasn't working.
You can quickly reset the password though. Try this:
Then you should be good to go.