Forum archive
MediaWiki Special:Import fails with error 500 on v12.0; works fine on v11.3 (SOLVED)
Deployed turnkey-mediawiki-12.0-squeeze-x86-ovf.zip with no problems. I went to access the Special:Import MediaWiki page which gives an HTTP 500 error. Fresh deployment, import attempted from default admin account. Tried again on a second fresh VM, same results. IE shows the 500 error, FF shows a blank page.
Deployed turnkey-mediawiki-11.3-lucid-x86-ovf.zip as a test, and import works fine.
Can't find a specific error in the logs to associate with the 500 error. I would prefer to run the v12 package, but require the import function to work. Help?
But ultimately a new appliance with a new version will be released. When that will be is anybody's guess at this point though...
Some of the other appliances have community member created update scripts (in the form of TKLPatches) so if you are particularly keen to see a newer appliance then perhaps that's something you could push for (by starting work on something like that for MediaWiki?)
The other thing to keep in mind is that it is possible that if the MediaWiki software comes from the Debian repos (rather than installed from upstream) that this bug is known and someone has figured a workaround?