Forum archive
No access rights in webmin and phpmyadmin
Hi Folks,
i´ve just installed the lamp on a new bare metal mashine and all good so far.
When i try to set a password within phpmyadmin i get the error
SET PASSWORD = PASSWORD( '***' )
#1133 - Can't find any matching row in the user table
#1133 - Can't find any matching row in the user table
1133 Can´t find any matching row in the user table
Also i cant create new Databases due to leck of rights
When i want to set some rights in Webmin (e.g. mysql server) i also get some error message:
"DBI connect failed : Access denied for user ''@'localhost' to database 'mysql'"
Searched a lot in the web, but got no hint. Any Ideas?
Thanks,elian
That's not good... I assume that you are using the LAMP iso to install.
By default with TKL you set the root MySQL password on first boot. As the username suggests if you log in with root (to phpMyAdmin/MySQL - using the password you set for MySQL on first boot) you should have total rights to everything MySQL. I assume you are using the root (MySQL) account!?
Assuming that you did all the above, then first thing I'd try is rerunning the firstboot scripts:
If that doesn't work then the only thing I can guess is that either your download was corrupt (or the iso iteslf - I once had an a corrupt SorceForge iso, resolved by downloading from a different mirror). Or perhaps a dodgey CD (assuming you burned it to disk).
Before you just try re-downloading though I'd check the integrity of the image.