Forum archive
TKLBAM error doing local backup on fileserver appliance - 'NoneType' object has no attribute 'backup_id'
I've installed the fileserver appliance (13.0) to a server and am trying to do a backup to a locally mounted file location. I have the API entered and tklbam seemed to initialize OK.
When I run:
tklbam-backup --address file:///mnt/tklbam/backup
I promptly get this:
Traceback (most recent call last):
File "/usr/bin/tklbam-backup", line 452, in <module>
main()
File "/usr/bin/tklbam-backup", line 351, in main
backup_id = registry.hbr.backup_id
AttributeError: 'NoneType' object has no attribute 'backup_id'What am I doing wrong?
Thanks in advance for any ideas or help.
From the other report it looks like something you did as part of the investigation (e.g., change the timestamp on the file) actually fixed whatever the problem was. In which case, it should be an easy fix. I need more information though to fix this.