Forum archive
Unable to connect to the Database: Could not connect to MySQL.
Hope someone can help me with this. Spent a lot of time reading different posts.
I am running a Proxmox VE 3.3 and KVM's work fine.
Now trying Containers based on turnkey templates.
Joomla 2.5 i am familiar with so tried to instll this. After installng the container boots and i
access the webinterface from a browser on it's IP-adres.
The first time configuration stops at step 4 where i get the error (See atached file).
" Unable to connect to the Database: Could not connect to MySQL."
Not so surprising since i dont know the databasename nor the username or password.
Where can i find this information??
I checked if mysql is running: yes it is.
with regards.
PH
Jeremy
I downloaded the template "debian-6.0-joomla_2.5-2_i386.tar.gz" via webui/storage/content/templates like you mentioned. It is indeed NO turnkey-OVZ. I scrolled down and found a real turnkey joomla 2.5 template.
The turnkey-init-file is not present on the debian-6.0-joomla_2.5-2_i386.tar.gz but that is no real surprise anymore.
For comparison i downloaded the wordpress tkl OVZ "debian-7-turnkey-wordpress_13.0-1_i386.tar.gz" and created a new container. With first login via SSH I DID see and autorun de initial setup. After that I was able to access te wordpress-dashboard :-).
With regards to the TKL Joomla: i got it up and running also after install and initial SSH-access configuration.
This is in the catagory "read better PH" i guess ;-).
So tnx Jeremy for your help! Wrong template was the problem here!
You realy helped me out here!
With regards,
PH