Forum archive
Can't restore from s3://s3.amazonaws.com as backup is on s3://s3-eu-west-1.amazonaws.com
Hi. I’m struggling with a recently discovered peculiarity of tklbam. It appears that I cannot restore a backup generated in AmazonWS ‘availability zone’ s3-eu-west-1, corresponding to Region: Virginia, on a server originally backed up in AmazonWS availability zone s3, corresponding to Region: Ireland.
If I do traceroute to s3-eu-west-1.amazonaws.com it gets through consistently (I’m in the UK), whereas if I traceroute s3.amazonaws.com the packets seem to just get dropped in the ether.
I can tklbam-backup OK – the files go to server: s3://s3-eu-west-1.amazonaws.com/tklbam-
But I can’t tklbam-restore, because it looks to server: s3://s3.amazonaws.com/tklbam-
It might in fact be worse – that tklbam-restore looks to s3 generically whereas backup send to s3-eu-west-1. I can’t test this as I’m already in a difficult position on a production server which didn’t restore when required.
The issue could be related to this: /forum/support/20150722/tklbam-restore-s3-failing-due-timeout, although there appears to be plenty of space. It could also be related to this, /forum/support/20130910/tklbam-s3-error-417 but I don’t actually get error 417, I just get a timeout.
Any suggestions will be greatly appreciated.
Regards,
Lee