I have tried numerous times, from both webmin & command line to restore a backup to a freshly created LAMP turnkey install on AWS.

The retore keeps failing with this message. What can be done to workaround?? I need to get to his backup set!

# duplicity --restore-time=2015-07-08T10:52:16 --archive-dir=/var/cache/duplicity --s3-unencrypted-connection s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp /tmp/tklbam-svnBCz
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Tue Jul  7 11:04:00 2015
Download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg failed (attempt #1, reason: timeout: timed out)
Download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg failed (attempt #2, reason: timeout: timed out)
Download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg failed (attempt #3, reason: timeout: timed out)
Download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg failed (attempt #4, reason: timeout: timed out)
Download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg failed (attempt #5, reason: timeout: timed out)
Giving up trying to download s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg after 5 attempts
BackendException: Error downloading s3://s3.amazonaws.com/tklbam-5oyc5tvjivkvmfvp/duplicity-full.20150707T110400Z.vol96.difftar.gpg

 

Replies (2)

Thanks for posting back Frank

Reply 1
That error message is very misleading. Good on you for hunting down the issue and thanks so much for posting back.

FWIW I have just posted a bug regarding this on our issue tracker here.

SOLVED -- even though the

Reply 2

SOLVED -- even though the error message indicates 'timeout' the problem was due to a DISK FULL.

Specifically, the /tmp volume must be large enough to hold the entire backup!!

Once I re-allocated the partitions by editing /etc/fstab so that the /tmp volume was on a larger drive & rebooting, the process was able to complete.