Forum archive
TurnkeyLXC container with owncloud. Database error. No mysql service running.
Hey Jeremy, I had owncloud up and running ok, and for unfortunately destroyed it, to work with a fresh install.
I did notice there are some cert files with owncloud still floating around on the root server lxc-containers that I use as my base operating system. (I don't think that's the issue, but just adding all the info I can.)
I immediately received the unknown domain error, and then on refresh received this error .
[Fri Jan 11 13:59:05.647560 2019] [:error] [pid 385] [client 192.168.0.11:31505] PHP Fatal error: Uncaught Doctrine\\DBAL\\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] No such file or directory in /usr/share/owncloud/lib/private/DB/Connection.php:62\nStack trace:\n#0 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\\DB\\Connection->connect()\n#1 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\\DBAL\\Connection->getDatabasePlatformVersion()\n#2 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\\DBAL\\Connection->detectDatabasePlatform()\n#3 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\\DBAL\\Connection->getDatabasePlatform()\n#4 /usr/share/owncloud/lib/private/DB/Connection.php(145): Doctrine\\DBAL\\Connection->setTransactionIsolation(2)\n#5 /usr/share/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\\DB\\Connection->__construct(Array, Object(Doctrine\\DBAL\\D in /usr/share/owncloud/lib/private/DB/Connection.php on line 62, referer: https://192.168.0.26/
I checked service --status-all and found mysql was [-] so I attempted to restart with service not found errors.
I tried all the db servers mysql, mysqld, mariadb, sqlite with all resulting in the same error.
I then went to github to see the latest changelog, and found that removal of the mariadb during security update as an issue.
How should I resolve? just re-install mariadb? I will try that, but leave this here, and only return if successful.
I tried the reconfig script owncloud.py as well and received the same error there right after setting the domain.