Forum archive
[Solved] Postfix error: SASL authentication failure: No worthy mechs found
I'm posting my fix for others to see in case this affects them too. Note: I'm a Linux noob and thus I had trouble with this far too long last night. (My 1st post here.)
Appliance: Turnkey Linux Wordpress
Problem: couldn't send email using the built-in Postfix server. (I used a free account with the built-in "SendInBlue" service).
mail.log contained this phrase: "SASL authentication failure: No worthy mechs found"
Issue: libsasl2-modules was either missing or out of date in the appliance.
Solution: at a Webmin command shell, I issued:
apt install libsasl2-modules
A pile of things installed. And then email worked.
Maybe someone can look into it.
I downloaded the appliance ISO about 3 days ago. I'm running it in a Hyper-V VM if that's a factor (likely not). And during the install, I ran the default updater for everything. And so this could be a current issue.
====
Credit goes to:
https://www.spamhero.com/support/125410/Set_Up_Postfix_to_Relay_Outbound_Messages_Through_SpamH
Specifically, the comment in the link was:
"If you see warnings such as "warning: SASL authentication failure: No worthy mechs found," or "SASL authentication failed; cannot authenticate to server ... no mechanism available," then you may need to install additional packages.
For CentOS, you may need to install cyprus-sasl and cyprus-sasl-plain (you may also need cyrus-sasl-lib, but our test on CentOS 7 didn't seem to require that package). On other systems, you may need libsasl2-modules.
"
There were other sites mentioning that libsasl2-modules could be the cause but this site suggested an answer that I could understand and so I tried it.
For reference, here is a more complete set of messages in the mail.log:
Apr 20 13:50:40 Wordpress1 postfix/smtp[10080]: warning: SASL authentication failure: No worthy mechs found
Apr 20 13:50:40 Wordpress1 postfix/smtp[10080]: 6303A5E08H8: to=<my-email@gmail.com>, relay=smtp-relay.sendinblue.com[185.107.232.248]:587, delay=1185, delays=1184/0.01/1/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server smtp-relay.sendinblue.com[185.107.232.248]: no mechanism available)
[the number: 6303A5E08H8 and the email address have been sanitized]
Sorry to hear of your troubles, but thanks for posting your solution. I'm sure that others will benefit.
It's worth noting that this oversight has been fixed in the latest version of Confconsole - which also includes a fix for Let's Encrypt HTTPS certificates. Unfortunately, the installation is a bit convoluted, but if you carefully follow the instructions (in a proper shell session, i.e. NOT in the Webmin shell) in the v1.1.2 release notes then certificates should work properly. It's a bit late now, but that would have also fixed this issue too...