Forum archive
TKL WordPress not working behind Nginx reverse proxy
Hi team,
I’ve got a turnkey linux wordpress VM running, and I want to put it behind my NGINX reverse proxy, as I’ve done with many of my other websites/appliances.
For some reason the Turnkey Linux Wordpress server is inaccessible outside the LAN using NGINX, with the exact same configuration that works for non-Turnkey Linux Wordpress websites.
I don’t know what it is about the Turnkey Linux instance that seems to break the reverse proxy, and so I’m hoping you might be able to steer me in the right direction.
Kind regards,
Hi Trent
Your use case certainly should work, although clearly there is something "not quite right".
Have you made any modifications to the default Apache config (that we ship with our WP appliance)? Also, are you proxying to http or https on your WP server? If proxying to https, you'll need to either get a proper cert on your server, or disable SSL verification (Nginx will fail to connect to https with a self signed cert by default). Actually, could you please share your Nginx reverse proxy config?
Also if you could please share the specific error message when it fails (my guess is that it's a 50x error - but be good to know for sure).
Look forward to hearing a few more details so hopefully we can get you up and running ASAP.