Forum archive
VirtualBox - Guest Additions Install Problem with XOOPS Appliance
I am running a clean installation of VirtualBox (6.1.38) on Windows (W11 Home 64-bit) and have imported the TurnKeyLinux XOOPS VM (16.1-buster-amd64) but am unable to install VBoxLinuxGuestAdditions (supplied with VirtualBox download), getting the following error messages:
/opt/VBoxGuestAdditions-6.1.38/bin/VBoxClient: error while loading shared libraries: libXt.so.6 : can not open shared object file: No such file or directory.
Remedied as ‘root’ by:
apt update
apt install libxt6 libxext6 libxmu6 (X11 components ?)
Kernel headers not found for target kernel 4.19.0-22-amd64. Please install them and execute /sbin/rcvboxadd setup
Remedied as ‘root’ by:
apt install linux-headers-$(uname -r)
apt install gcc make perl
/sbin/rcvboxadd setup
On reboot VBoxGuestAdditions are not mounted so I reran :
sh ./VBoxLinuxAdditions.run
which then gives this error:
Failed to connect to bus: No such file or directory
I’m stuck. Help please. :)
(I also tried building from the 17.1 .iso but got the same errors).
Firstly, there is a new v17.1 release of our XOOPS appliance. It's only available as an ISO at this point, so you'll need to install it to a new VM (rather than import it - I suggest at least 2x vCPUs, 2GB RAM and 20GB minimum root volume). But if you want a newer OS (with newer versions of other software and a longer time until it reaches EOL) then I suggest starting again with that. Apologies that I didn't mention that yesterday. I still haven't finished so they're not "officially published" yet - I still need to upload the changelogs and do a blog post. But the ISO is good to go if you're interested.
Also, (something else I perhaps should have asked about sooner) I'm curious what you're using your server for that would require installation of "VBoxLinuxGuestAdditions"? AFAIK, it's only needed if you plan to pass through USB devices?! Everything else should "just work" without dedicated VirtualBox extensions. We do pre-install the VMware extensions, but they actually include VMware specific drivers that give better disk and network performance. I'm almost certain that that's not the case with VirtualBox (hence why we don't make it easier to install them).
Having said that, perhaps there is something that I'm missing? If there is value in making it easier to install VirtualBox guest addons, then perhaps we could write a simple helper script to save future users some headaches?
Seeing as it's a headless server, personally, I'd run the server in "headless mode" (use the GUI for initial setup, but once installed, relaunch in headless mode so yuou don't have the VM window cluttering up your desktop) and interact with your server via SSH/SFTP/SCP. So even though it's running locally, you're interacting with it as if it were any other remote headless server.
As you're running Windows, you'll need to install client software to do that. E.g. tools such as OpenSSH (SSH), PuTTY (SSH), WinSCP (SSH/SFTP/SCP) and/or Filezilla (SFTP/SCP)) and/or Webmin (HTTPS on port 12321).
If you'd rather keep going with v16.1, that message "/usr/share/initramfs-tools/scripts/live-bottom/25autologin : Can’t open /scripts/functions" can safely be ignored. It doesn't actually cause any issue (beyond the message). It's just left over cruft from the live ISO functionality (all alternate build types are constructed from the ISO) and IIRC it should be fixed in the new release.
If you don't want to just ignore the message, you could just delete that file. Actually, you could delete all of the "live-*" directories in /usr/share/initramfs-tools/scripts. I.e.:
I anticipate no issues, but as per always; create a backup and/or snapshot of your VM before doing anything of any significance such as this (that might cause a whole world of pain if you do a typo).
Good luck with it and I'd be interested to hear which way you go and why.