Hi people,

I appreciate very much your work! It's better than our at http://virtualappliance.manthys.it... ;-)

So we decided to turn our project to Open virtual appliances based on TurnKey Core and try to collaborate with this community.

Our first work has been XMail Server (XMail Server 1.25 + PHPXMail 1.5 + Uebimiau 2.7.2). It has been build as a VMware Virtual Machine and you can download it from http://www.megaupload.com/?d=S1W7XCTE

I hope it can join to the TurnKey Virtual Appliance's family.

Thanks

Andrea

 

Replies (6)

Firstly, welcome! It's great to...

Reply 1
Firstly, welcome! It's great to have you guys part of the community.

If you haven't already, take a look at the community development page, and TKLPatch - a simple appliance customization mechanism. Sharing patches with the community will help accelerate development and simplify the process of adding it to the TurnKey library.

Once an appliance is added to the project, we assume the burden of maintaining it at the appliance level with regular updates. This frees you to focus on more interesting tasks (e.g., improving quality of integration, software sub-components).

Looking forward in collaborating with you guys!

Bugfixed tklpatch to support applying patches to running system

Reply 2
Firstly, welcome Gabriele. You should create an account so you get email updates when threads that interest you are updated.

You don't need to tar and gzip your patches, just use the tklpatch-bundle command.
tklpatch-bundle path/to/patch-dir
Your question prompted me to test patching a running system and I found a couple of bugs, so I just released v0.93 (github and package archive). Note that applying patches to a running system is possible, but not the primary use case of tklpatch, so you need to make sure the running system is configured according to the tklpatch expected state.

For example, before applying the example drupal5 patch in an installed LAMP appliance, I had to:
mysql-admin --user=root --password=PASSWORD_SET_DURING_INSTALL password ""
/etc/init.d/mysql stop
/etc/init.d/apache2 stop
tklpatch-apply / drupal5.tar.gz
Putting the above aside, it looks like the error message you received is unrelated, so if you could prepend TKLPATCH_DEBUG=y to tklpatch-apply / patch.tar.gz it might help in figuring out what went wrong.

thanks Alon

Reply 3

Alon, thanks very much.

The problem that i have with the command "tklpatch-apply" is solved with your new release of the program.

how you did, yesterday, i have take a test with your drupal5 example, and i had a problem too. Now with new release i don't have.

But i have another problem, when i install xmail with "apt-get" command, i have an error and the tklpatch-apply exit of the script and it's not execute the next commands in the "conf" file.

So i know this error depending on an error about xmail automatic installation, but i have found a solution to correct the installation: indeed i  need to copy some file at the end of the xmail installation to resolve that.

So do you know if there is a method to force the execution of the conf script if also there is an error on apt-get execution?

 

thanks

Gabriele

Its best to preseed

Reply 4
Glad the latest version is working for you.

If a package installation fails, apt-get will return a failed exit code and therefore the conf script will exit (due to #!/bin/bash -e). Just for sake of argument, what you are asking for is something like this:
apt-get install package || true
But, DON'T DO THAT. It's bad practice and will get you in trouble later on.
The correct way is to preseed the package before installing it, take a look at some notes I made about pre-seeding here.

Hope that helps.

New TKLPatch section on development wiki

Reply 5
I have created a new section in the development wiki for TKLPatches, and have added this patch to the list. Feel free to update the patch page as you see fit.