TurnKey Linux Virtual Appliance Library

All TKLBAM backups missing after second backup? (FIXED)

Hi,

I'm testing out the new TKLBAM backup system (which is a great idea btw.) I set up a core appliance yesterday and successfully made my first backup that showed up at the  hub.turnkeylinux.org site. After my second backup (26Gb), which completed without errors, there are now no backups listed at all at hub.turnkeylinux.org.  Is there something obvious I should check or that I might be doing wrong? 

Below is the tail of my second back up log together with the output of tklbam-list:

Thanks!

 


…
A var
A var/www
A var/www/index.html
Uploading s3://s3.amazonaws.com/tklbam-lmpxxxxxv4/duplicity-inc.20100909T141548Z.to.20100910T054031Z.vol539.difftar.gpg to STANDARD Storage
Processed volume 539
AsyncScheduler: task execution done (success: True)
Uploading s3://s3.amazonaws.com/tklbam-lmpxxxxxv4/duplicity-new-signatures.20100909T141548Z.to.20100910T054031Z.sigtar.gpg to STANDARD Storage
Uploading s3://s3.amazonaws.com/tklbam-lmpxxxxxv4/duplicity-inc.20100909T141548Z.to.20100910T054031Z.manifest.gpg to STANDARD Storage

--------------[ Backup Statistics ]--------------
StartTime 1284097232.08 (Fri Sep 10 05:40:32 2010)
EndTime 1284111987.51 (Fri Sep 10 09:46:27 2010)
ElapsedTime 14755.43 (4 hours 5 minutes 55.43 seconds)
SourceFiles 18466
SourceFileSize 29774041705 (27.7 GB)
NewFiles 18423
NewFileSize 29771168493 (27.7 GB)
DeletedFiles 0
ChangedFiles 11
ChangedFileSize 2810408 (2.68 MB)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 18434
RawDeltaSize 29767122879 (27.7 GB)
TotalDestinationSizeChange 28247184863 (26.3 GB)
Errors 0
-------------------------------------------------

root@ xxxx:/usr/local/galaxy# tklbam-backup
root@xxxx:/usr/local/galaxy# tklbam-list
# ID  SKPP  Created     Updated     Size (GB)  Label
   1  Yes   2010-09-09  2010-09-09  0.00       TurnKey Core


Liraz Siri's picture

I've never seen this bug before

Martin, it looks like you ran into a new kind of bug. We'll have to investigate and get back to you. If possible we'll fix this in a way that doesn't require you to recreate the backup.

  FYI - I just ran backup

 

FYI - I just ran backup #3 after a few smaller changes and it seems to recognize that the previous large (26Gb) backup was carried out successfully. The delta this time was only ~10Mb. tklbam-list still shows no backups however.  

Don't worry about me having to recreate the backup - I'm just testing at this point anyway. Also, let me know if I can send you any other useful info.

Martin.

Alon Swartz's picture

Fixed

Your data was backed up successfully, the issue was related to the Hub's caching mechanism of the backup size (IntegerField instead of BigIntegerField). After updating the database schema, everything is working as it should.
 
I triggered the cache update of your Backup Records in the Hub, so they will now appear in the Backups dashboard.
 
Thanks for reporting the issue, and helping us work out the kinks of the beta release. If you come across any other issues, let us know.

Thanks for the quick fix -

Thanks for the quick fix - Everything is working smoothly now. I'm migrating several machines over and looking forward to the easy backups!

same issue

 

I have the same problem
...
--------------[ Backup Statistics ]--------------
StartTime 1305984247.23 (Sat May 21 10:24:07 2011)
EndTime 1305984285.86 (Sat May 21 10:24:45 2011)
ElapsedTime 38.64 (38.64 seconds)
SourceFiles 33989
SourceFileSize 403189746 (385 MB)
NewFiles 333
NewFileSize 1989003 (1.90 MB)
DeletedFiles 4
ChangedFiles 540
ChangedFileSize 7910364 (7.54 MB)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 877
RawDeltaSize 819690 (800 KB)
TotalDestinationSizeChange 787703 (769 KB)
Errors 0
-------------------------------------------------
 
$ tklbam-status
TKLBAM:  Backup ID #1, Updated Sat 2011-05-21 10:22
$ tklbam-list
# ID  SKPP  Created     Updated     Size (MB)  Label
   1  No    2011-03-08  2011-05-19  447.53     SIGMA - Integracion
   2  No    2011-03-10  2011-03-23  128.59     Sigma-IT - Servidor de integracion (hardy)
   3  No    2011-03-26  2011-03-26  164.07     TurnKey LAMP Stack
Alon Swartz's picture

Different issue

The discussed issue has been fixed. I think this was the issue.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)