TurnKey Linux Virtual Appliance Library

ESXI 4.1 'debian6' is not supported

Hello.

I am trying to run the turnkey revision control appliance in ESXI 4.1, as I only have access to a Dell GX620 for my testing.

However, when I start up any of the turnkey appliances, I get the message that

-->       Guest operating system 'debian6' is not supported

 

Any ideas on how to work around this problem, or is my ship sunk?

 

Thanks,

 

Bruce.

Eric (tssgery)'s picture

I'm running on ESXi 4.0 and 4.1

I run my VM's on ESXi 4.0 and 4.1 without issue. Are you deploying the OVF or installing from ISO?

 

Most of my VMs are installed from ISO, when creating the VM I pick the Linux->Ubuntu 32 bit option and have no issues. I have successfully deployed OVFs too though. Tell me how you deploy the images and I'll try to recreate the issue.


ESXI 4.1

Hello.

 

I was unzipping the appliance into it's own directory, then importing the folder through the Datastore Browser. Once it is imported, I add the VM into the inventory.

Thanks,

Bruce.

Eric (tssgery)'s picture

OK...

I got a little further but it appears that the vmdk being built and distributed as part of the vmx/vmdk bundle is a newer format than my ESXi 4.0 instance can handle.

What I did was to copy the vmx/vmdk to my datastore and use the Datastore browser to import the vmx into the inventory. When I tried to start it, I got the same error as you... 'debian6' not supported. I then edited the VM properties and changed the settings so that VMware thoguth the guest VM was 'Ubuntu 32 bit'. I could then power on the VM but did not get much further. I got the following error:

Failed to opem disk scsi0:0: Unsupported and/or invalid disk type 7...

You might be able to use a couple of different tools to convert the disk to an older format if you really want to (look at vmware-vdiskmanager and ovftool).

But, if I were you... I'd just create a VM from scratch and install from the ISO images of the TKL appliances. Or, deploy the OVF files if you have a vcenter instance available.


Downloading ISOs

Hello.

The errors you are seeing are exactly what I was seeing. Debian 6 is not supported with 4.1, and I suspect that it wont be.

Not having been a system administrator for 20 years or so, I was hoping to run the VMs the easiest way.

I have now downloaded the ISO, and will give it a go to install that way.

Thanks for your help,

 

Bruce.

Eric (tssgery)'s picture

ESXi 4.1 was release well before Debian 6

.. but this is not a debian 6 issue. The vmdk being built by and distributed by TKL is a newer format than ESXi supports. VMware is likely not going to go and backport vmdk v7 support into ESXi 4.1

If you need to stick with ESXi 4.1, your option is to deploy from an ISO (it's very little more work than the vmx/vmdk) or to use something like ovftool to convert the vms/vmdk to an older format that ESXi 4.1 supports.

If you can migrate to ESXi 5.0, it's still free and will support what you're doing.


ESXi 4.1

Hello.

'Not a debian issue'  : Sorry, I guess I wasn't clear. I agree it is not a Debian 6 issue. I just meant that I didnt think that VMWare was going to change an old product (4.1) to support a new OS.

In any case, I have installed via the ISO, and it is working quite well now.

Thanks very much for your assistance.

Bruce.

Eric (tssgery)'s picture

I'm glad you got it going

FWIW, I deploy most of my VM's by creating the VM from scratch and installing from the ISO manually. I am prompted for a little more information (like the disk size and lvm) but I find that I don't always want what the good guys at TKL have pre-decided. You could deploy the OVF format but you'd need a VMware vCenter instance up to do so.

 

Anyway, I'm glad you got it working. By all means, post back if you have other issues or find any tricks. 


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)