TurnKey Linux Virtual Appliance Library

Repository Appliance: Incomplete SASL installation?

Markus KARG's picture

I want to use LDAP authentication for svnserve, so I set up all the needed steps but not the last one: I need to put MECHANISMS="ldap" into the file /etc/default/saslauthd. But that file does not exist, so obviously SASL is not installed completely (some parts seem to be there, as sals2 directories do exist)?

What to do?

Markus KARG's picture

Yes, SASL is incomplete in the repository appliance!

I found out where the problem comes from and how to fix it. It would be great if future releases of TKL would have this fixed right from the start:

SASL2 is only partially installed, but svnserve needs it complete. To make svnserve support SASL2, it must be completed manually using the following command:

apt-get install sasl2-bin libsasl2-modules libsasl2-modules-ldap

After that is done, the config file is where all the svn HOW-TOs tell: at /etc/default/saslauthd. :-)

sasl config on Suse

Hi,

I'm in front of the some problem where i follow svn tutorial to configure ldap authentication..

So i checked those librairies (libsasl2-modules libsasl2-modules-ldap) and they are not available for Suse Enterprise Edition SP2

Otherwise, i wonder if i can configure sasl just with /etc/init.d/saslauthd and /etc/sysconfig/saslauthd because i found the parameter that i want to change :

SASLAUTHD_AUTHMECH=ldap

 

any idea ?

tks

TKL is basing on Debian, not on SuSE

TKL is basing on Debian, not on SuSE. So what is your actual problem with this appliance?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)