TurnKey Linux Virtual Appliance Library

Samba / Windows XP - Folders not refreshing

Aris Moratalla's picture

Hi Guys!

I done setting up Turnkey File Server.But I am having refresh problem with Samba shares.  For instance, when a user on Windows XP goes to create a new folder, it doesn't appear unless you go to "view -> refresh' and you will notice the change.  This happens with renaming, deleting, etc.

Can anyone offer a suggestion so you can instantly see changes done from Windows XP to samba shares.
 
Thanks and regards!
 
Aris

 

Jeremy's picture

It's Windows I reckon

Have a look at #199 on this list.

If that doesn't fix it then there is also a possibility that a service running on your Win PCs is interfering with Explorer. Use msconfig to disable all services (except MS ones) and check it (after reboot). Hopefully auto refresh is working again now.

Assuming that auto refresh works then go through your services to work out which one is the culpret.

Easiest way I reckon is to enable half, test it. If it still works, enable half of what's left and test again. As soon as it doesn't work, disable the half you just enabled (which failed test) and enable the other half (of what's left). Do you get me? Sorry it sounds confusing!

Other than that I've got no clue. Be interested to hear how you go though. A Server 2k3 machine at work does it too (only network folders not local ones) but I haven't botherred to fix it.

Aris Moratalla's picture

Hi JedMeister! I dont really

Hi JedMeister!

I dont really know what happened. I happened to restart my turnkey file server and got to work on samba share again and I found out that the samba shares are now refreshing smoothly.

I still have no clue about this but I'm glad my file server is running well.

Thanks and Regards Jed!

Aris

Jeremy's picture

Hmm strange!

Well at least its working now.

Sounds as if it actually was something to do with Samba (rather than Windows) but it may be useful to keep in mind if you come across the problem again. Its not all that common but I have come across it a few times (even in Windows only environments).

Perhaps Samba just needed a restart. Unlike Windows, generally with Linux restarting the individual service is generally all that is required (not a full reboot), although in this case perhaps it was something else that needed restarting.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)