TurnKey Linux Virtual Appliance Library

Wordpress

I am using the wordpress and i cannot get the host name to appear in the IP address. Only the IP address will show even if you call on the url. I have been all around web min and can not seem to find how to change it.

 

Thanks for any help

Liraz Siri's picture

Don't understand what you mean

Hi Tim,

I'd love to help you get to the bottom of your problem but I can't make sense of your question. Could you provide more information on precisely what you are trying?

When you visit the site, the

When you visit the site, the address bar displays the IP address of the blog rather than the name of the site. The name of the site is crucifiedwithchrist.fbcwalton.org and when you go to the site, it will display 216.196.161.121 instead of the crucifiedwithchrist.fbcwalton.org. How can i get it to display it in the address bar?


Jeremy's picture

Looks like you'll need to contact your Domain provider

From Windows I just ran

nslookup crucifiedwithchrist.fbcwalton.org

and got this response

Non-authoritative answer:
Name:    crucifiedwithchrist.fbcwalton.org
Address:  64.202.189.170

This suggests to me that the nameservers your domain name are registered on do not actually point to your server (216.196.161.121) but another server (64.202.186.170). This seems to be a somewhat common practice with some hosting companies. Basically they point the domain to their own servers by default. If you then host your own site then they redirect it to your IP.

Assuming I'm right, there are a number of ways to create the situation you want but unless you can directly configure the nameserver yourself to point straight to your IP then you'll need to negotiate with the domain name provider.

[edit]
Actually.... Just realised that it's a subdomain. Not sure how I missed that!? That info may or may not change what I've written above.
Are you running your main site (fbcwalton.org) locally? (ie either VM or bare metal on your own equipment)? If so you may be able to change the apache redirect works to create your desired effect.

Depending on the setup (hence the question) you may be able to change the way the redirect takes place. Even if your main site is hosted then you still may be able to do it (depending on how much control the host provides).

I have just been having a bit of a read online and I'm sure there's probably also a way to change this in apache config (on your TKL) but you'll need to do some serious googling or get some advice from someone with much more knowledge than me (like Liraz ).

Liraz Siri's picture

DNS misconfiguration

JedMeister's answer is spot on. This is a DNS mis-configuration issue. You used the wrong GoDaddy configuration option. Instead of using GoDaddy's redirection service you should have setup the record for that subdomain by adding an 'A' record that points that to your IP. If you don't know what that means you'll need to either learn how to setup DNS correctly by yourself, or get your Internet Provider (FUSE internet, right?) to do it for you. They might charge you a bit for it, but it's generally not expensive.
$ host -t a crucifiedwithchrist.fbcwalton.org
64.202.189.170

$ whois 64.202.189.170

OrgName:    GoDaddy.com, Inc.
OrgID:      GODAD
Address:    14455 N Hayden Road
Address:    Suite 226
City:       Scottsdale
StateProv:  AZ
PostalCode: 85260
Country:    US

Thanks! I added the record

Thanks! I added the record like you said and works perfect.

  Ya I run everything

 

Ya I run everything locally. I am running the main site on windows server 2003 and the blog on a old box with the turnkey word press. I could not get the word press to run right on server 2003 so I saw the turnkey Linux and thought this would be easier.  They are both running on separate IP addresses.  When you type the domain name in to the site it will take you to the blog but will display the IP address of the server and not the domain name. Ive been trying to find the awnser just cant find the light at the end of the Tunnerl per say. I tried it on another box with Ubuntu and can get the name to show up in the address bar but am not able to get the server to respond to outside request.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)