TurnKey Linux Virtual Appliance Library

newb file server question

I've added a user through the extplorer page.  When logging in as that user, it states the file storage location doesn't exist.  Is this not created when the user is created with supplied info?

Update: I went into webmin and manually added a storage folder /srv/storage/username.  I log in now to that user with no problem, but when trying to upload a file it fails.  No error code - just says error, upload failed.

Jeremy's picture

There are 2 levels of permissions (just like in Windows)

You have file level permissions and share level permissions. The file level permissions apply to the Linux user and the share level permissions apply to the Samba user. I suspect that you have the correct Samba (share) permissions but not the Linux user (file) permissions. That is why you can see the shares but not actually do anything with them. The other possibility is that the user only has read (Samba) permission and not read/write.

I'm not very familiar with Extplorer but I suspect that the TKL fileserver uses Samba users with the Extplorer program. By default it should be set up to sync Linux & Samba users, but for good measure I usually manually sync them - on the Samba page in Webmin there's a button "Sync Linux & Samba users" (or something similar). While you're in Webmin-Samba go into the share and ensure the user is added as having read/write access. Then go back to the main Webmin Samba page and "restart Samba". Now still in Webmin, also go to the Users (Linux users that is) and add your user to the smbusers group.

If all those things are right it should work. Sorry if my instructions aren't very clear. Please ask for more details if there's something you don't understand or doesn't make sense. Good luck!

Jed, I agree with your

Jed,

I agree with your assessment re user/group rights.  However, when a user is added through the extplorer interface, I can't find a corresponding unix or samba user.  I'm going to have to spend some more time this obviously.  I did create a unix user and chose auto sync.  Still no luck.  Checked out all the folder and file rights both unix and samba.  Still no luck.

Pressley


Jeremy's picture

I've done a bit more reading & testing and this is what I found:

It seems that my initial suspicions were incorrect. Sorry that I lead you astray.

eXtplorer does not use Linux or Samba users, it has its own separate user database. So eXplorer users are completely separate again and must be added/edited separately (and unfortunately manually). I've done a bit of a writeup on another thread, have a read over here. You may wish to read the previous post (that I was replying to) to get the context of some of my comments.

Hope thats helpful (or at least more helpful than my initial comments).

JedMeister, I think I got

JedMeister,

I think I got it to work.  I changed the ownership of the storage folder to the www-data group and upload is now available.  Not so bad administratively, unless I get hundreds of users.  New users get the home folder as /srv/storage/username.  Upload and download is functioning.


Thanks for the help and extra

Thanks for the help and extra work.  Extplorer does seem like an odd bird in that these processes are not intertwined, one would think that is the point of having a file server appliance.  My desire for this is in a law firm to make sensitive documents available for clients.  The way mine is set up now, the user is able to download a file but not upload.  Could work out that way, but would prefer it to be upload and download.  Your comment on the other post would make this completely too much work.

Pressley


Alon Swartz's picture

eXtplorer net2ftp backend

Hey folks, sorry for the late reply. We are in the middle of a development cycle, and I am putting the Core Lucid beta through final testing before release, so I haven't been around the forums much.

I just wanted to say that the fileserver (and domain-controller) appliances with eXtplorer include the vsftpd binded to localhost to provide net2ftp backend. You'll notice it is one of the connection methods available when logging into eXtplorer.

When connecting via net2ftp, it provides users access to their home directories, as well as workarounds permission issues with eXtplorer.

This is actually documented on the appliance page, maybe we should emphasize it more.

Hope the above helps.

Alon, I don't see where

Alon,

I don't see where that option is available when logging into extplorer.


Jeremy's picture

Glad you got it working

BTW "FTP mode" is available by clicking a link in the top RH corner of the eXplorer page once you have logged in.

Did you use FTP mode to get your desired results?

PS thanks Alon, I had just been reading about FTP mode. IMO it'd be great if you could just log in directly to FTP mode, but I guess that's a feature request for the eXtplorer dev...

I looked as well...

Alon,

I looked as well but alas did not see an FTP option at the extplorer login screen.

However once logged into extplorer there is an option to switch to ftp mode and clicking that brings up another login prompt which then any defined linux user may enter their info and login only to their directory.

The ability to ftp login to extplorer from a web browser would be a good thing. And it would be nice to set that option as a default somewhere in a config file... Then extplorer follows the linux users and no admin for the admin!
 

Thanks

Dave


Jeremy's picture

I agree about being able to log straight in to 'FTP mode'.

but I note that this was suggested/requested on the eXtplorer forums a long time ago and obviously hasn't been enacted. So don't hold your breath...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)