TurnKey Linux Virtual Appliance Library

Webmin on 12321?

Hi! Noob here. I discovered Turnkey about a month ago and I think is't fantastic. Top marks! However, I'm struggling to get to the Webmin interfaces on any Turnkey (Using mediawiki and projectpier). 12321 connections are refused, but I can get to phpmyadmin on 12322 fine.

Thanks

Jeremy's picture

Security certificate previously rejected?

Just a thought...

Webmin uses SSL encryption so you need to connect via https, but because it is a self signed security certificate, it will bring up a warning first time you go there. If it is initially refused/blocked then further attemps will most likely result in some sort of connection refusal.

To see if that may be the problem, try using the port under http (ie http://xxx.xxx.xxx.xxx:12321/ - where xxx.xxx.xxx.xxx is your server IP). It won't work (it'll throw up a "Error - Bad Request  This web server is running in SSL mode. Try the URL https://xxx.xxx.xxx.xxx:12321/ instead." message) but it will potentially confirm that traffic to port 12321 is not being blocked somewhere else.

Nope, that's not it...

I've tried both and i've tried to find a webmin conf file to see if the config is correct, but I can't find any reference to port config. I don't get a bad request error on either, just a cannot connect. I have also confirmed I'm not blocked by anything else.

I'm running webmin on other Debian systems on the default port 10000 and I'm connecting to them fine.

Thanks for your help.

Liraz Siri's picture

Probably something on your network

There's probably some kind of filtering between you and the appliance that is preventing you from accessing webmin.

To verify that webmin is bound to port 12321, run netstat:

netstat -atn|grep LISTEN
If port 10000 works for you, you can reconfigure the port webmin binds by editing /etc/webmin/miniserv.conf.
sed --in-place "s/12321/10000/g" /etc/webmin/miniserv.conf
/etc/init.d/webmin restart
Hope this helps!

Top Tips!

Thanks...

netstat shows that the system is listening on 12321

webmin config here

root@mediawiki:~# cat /etc/webmin/miniserv.conf
port=12321
addtype_cgi=internal/cgi
realm=Webmin Server
logfile=/var/webmin/miniserv.log
errorlog=/var/webmin/miniserv.error
pidfile=/var/webmin/miniserv.pid
logtime=168
ppath=
ssl=1
env_WEBMIN_CONFIG=/etc/webmin
env_WEBMIN_VAR=/var/webmin
atboot=0
logout=/etc/webmin/logout-flag
listen=10000
denyfile=\.pl$
log=1
blockhost_failures=5
blockhost_time=60
syslog=1
session=1
premodules=WebminCore
userfile=/etc/webmin/miniserv.users
keyfile=/etc/ssl/certs/cert.pem
passwd_file=/etc/shadow
passwd_uindex=0
passwd_pindex=1
passwd_cindex=2
passwd_mindex=4
passwd_mode=0
passdelay=1
sudo=1
preroot=theme-stressfree
root=/usr/share/webmin
mimetypes=/usr/share/webmin/mime.types

I tried switching ssl off and changing the port to 10000 but no joy..

Any Thoughts?

Much Obliged Sir..
 

Ah ha!

I spotted the obvious mistake I'd made... Do'h. I had changed LISTEN= but not PORT=, once they were both on 10000 and SSL=1 it worked a treat. Then bizzarely I changed them back to 12321 and it worked... hmmm.

Oh well, fixed.

Thanks for your help. Much appreciated.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)