TurnKey Linux Virtual Appliance Library

Zimbra Appliance Keep Getting error during config script!

 Every time i run "/usr/local/bin/zimbra-conf myhost.com mypassword" I get this error

 

 

Host mail.example.com
        Stopping stats...Done
        Stopping mta...Done
        Stopping spell...Done
        Stopping snmp...Done
        Stopping archiving...Done
        Stopping antivirus...Done
        Stopping antispam...Done
        Stopping imapproxy...Done
        Stopping mailbox...Done
        Stopping logger...Done
        Stopping ldap...Done
Failed to start slapd.  Attempting debug start to determine error.
daemon: getaddrinfo() failed: Name or service not known
 
Have Checked all the forms have not yet found on post with this error or any idea on how to fix it. If any one knows what is up could really use the help. Thanks All

Found the Fix

I give credit to the original poster over at vps.net. The answer is out there you just got to SEARCH HARD and learn to read.

METHOD 1

Create the Zimbra VPS and then login to it via SSH, once logged in issue the following commands:



Code:
	su - zimbra
zmlocalconfig -e ldap_url=ldap://localhost:389
zmlocalconfig -e ldap_master_url=ldap://localhost:389
zmlocalconfig -e ldap_port=389
zmlocalconfig -e ldap_host=localhost
/usr/local/bin/zimbra-conf DOMAIN ADMIN_PASS

Replace DOMAIN with the domain you want it to setup so that it sets up mail.domain.com and replace ADMIN_PASS with a proper password.

The last command may show some errors but it doesn't seem to affect anything so once its done restart the VPS and once restarted browse tohttps://VPS_IP:7071 and login with admin@domain.com and the admin password you entered.

Method 2

Create the Zimbra VPS and then login to it via SSH, once logged in issue the following commands:



Code:
	su - zimbra
zmlocalconfig -e ldap_url=ldap://localhost:389
zmlocalconfig -e ldap_master_url=ldap://localhost:389
zmlocalconfig -e ldap_port=389
zmlocalconfig -e ldap_host=localhost

zmcontrol stop
/opt/zimbra/libexec/zmsetservername NEW_HOSTNAME
zmprov createDomain domain.com
zmprov ca admin@domain.com test123 zimbraIsAdminAccount TRUE

Replace DOMAIN with the domain you want it to setup so that it sets up mail.domain.com and replace test123 with a proper password.

The last command may show some errors but it doesn't seem to affect anything so once its done restart the VPS and once restarted browse tohttps://VPS_IP:7071 and login with admin@domain.com and the admin password you entered.

Hope that helps!

Jeremy's picture

Good work, thanks for posting back

Sorry no one here could help you out, but good on you for finding the answer. And better still, coming back and sharing with the TKL community. I'm sure this will help someone in the future.

Error in proceedure

http://pastebin.com/RAzKGRjw

[zimbra@mail ~]$ zmcontrol stop
Host -n
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
[zimbra@mail ~]$ zmlocalconfig -e ldap_url=ldap://localhost:389
[zimbra@mail ~]$ zmlocalconfig -e ldap_master_url=ldap://localhost:389
[zimbra@mail ~]$ zmlocalconfig -e ldap_port=389
[zimbra@mail ~]$ zmlocalconfig -e ldap_host=localhost
[zimbra@mail ~]$ /opt/zimbra/libexec/zmsetservername mail
ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException localhost:389)
Host -n
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
Started slapd: pid 27170
ldap_initialize( ldap://localhost:389 )
adding new entry "cn=mail.domain.com,cn=servers,cn=zimbra"

ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.net.ssl.SSLPeerUnverifiedException hostname of the server 'localhost' does not match the hostname in the server's certificate.)
[zimbra@mail ~]$ zmprov createDomain domain.com
ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
[zimbra@mail ~]$ 

some things I did before

Sorry about the spaces on the above post. I will just paste the link now.

http://pastebin.com/UXfTMUfe

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)