TurnKey Linux Virtual Appliance Library

Magento domain issue / local testing

Hi, I'm having issues accessing my magento appliance via a web browser. When I try to type in the IP address assigned by my home dhcp server, it just forwards to whatever the domain setup was, shop.example.com

 

I just want to test with the http://ipaddress/

 

What do I need to do?

Jeremy's picture

You can reset the domain/url

You just need to re-run the first boot script. From the commandline:

/usr/lib/inithooks/bin/magento.py

I think that you should be able to use an IP address rather than a FQDN.

Another way (or if it won't let you set an IP) is to leave the appliance as-is and just add an entry to your local machine hosts file (ie the machine with the web-browser you are trying to use). To do that I suggest you google your specific OS and you should find easy instructions on that. Basically you will just need to point the FQDN to the IP.

Works like a charm!

Thanks Jeremy!

setting the ip in the script

setting the ip in the script worked. Thanks.

Jeremy's picture

No worries

Glad to hear it worked, and good to know for sure for future reference. Thanks for posting back.

Worked for Me!

Hey Thanks! I had same issue and this worked for me.................

Brilliant!

/usr/lib/inithooks/bin/magento.py

the solution is to set the ip you get from vmware appliance into the domain requested when you launch the reconfiguration with:

/usr/lib/inithooks/bin/magento.py

 

CIAOOOOOOOOOOO

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)