TurnKey Linux Virtual Appliance Library

no external access to tk wordpress, firewall?

I had a working server hosting a wordpress blog i setup manually with ubuntu.  Its power supply died so I decided to go with turnkey wordpress. Its awesome but I can't seem to get to it from the internet.

I have a static IP set for the turnkey server.

I have ports 80,443,22 forwarded to my new turnkey server static IP in my router.

I have a dyndns hostname saved in the WP options table.

If I change my hosts file on another lan computer and browse to the dyndns name it works.

I checked whatsmyip.org and try to go to the external IP, or the dyndns name, and neither work. Its like the router port forward isn't working... but its very simple to setup and was working before.

So I ask, is there a firewall rule in the turnkey wordpress I need to set?  Or some kind of networking setting I am missing? PHP setting? I've tried re-setting up the port forward rules and restarting my router a few times.

FIXED

I searched a bit more then decided to make sure the server could talk to the internet at all. 

ping www.google.com
connect: network is unreachable

So with a little more searching I found this which fixed my networking.  Replace 1.1.1.1 with your router's IP.

/sbin/route add -net 0.0.0.0 gw 1.1.1.1 eth0

Jeremy's picture

Strange...

Glad you found a fix, but I'm not really sure why you had the problem. I have (and am) using TKL in a similar config to what you describe in your initial post and have had no issues. It just works OOTB. The gateway should be able to be set from the ConfConsole when you set a static IP and should work fine. I assume you set a static IP?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)