TurnKey Linux Virtual Appliance Library

Issue with dynamic DNS in the hub

Leandro's picture

Hi TKL folks,

I've recently discovered your tklapp.com dynamic DNS and decided to switch out my Elastic IP for talentware-trac.tklapp.com for one of my instances running through the Hub.

First issue was that when I released the Elastic IP, Amazon didn't assign me another public IP address. Solved this by rebooting the instance from SSH.

Then I installed the hubdns package, ran hubdns-init and hubdns-update, which returned successfully but did nothing (i.e., DNS didn't resolve).

I then looked at the Hub and, despite the reboot, it still believed my instance had the old (now released) Elastic IP, and talentware-trac.tklapp.com wasn't linked to it. I decided to reboot again, this time from the Hub interface.

After this second reboot, the public (dynamically-assigned) IP was correct, and talentware-trac.tklapp.com appears as associated to it. However, the DNS resolution still doesn't work. hubdns-info reports it correctly, but when I ping I just get back the tklapp.com root IP.

Please help!

Leandro

Jeremy's picture

Seems to be working now...

I just had a quick look and it seems to be working now! So I guess it must've just taken a little while to propagate?

Leandro's picture

Indeed!

Wow, must have happened in the last 5 minutes. Thanks!


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)