TurnKey Linux Virtual Appliance Library

/root/.bashrc ignores global PATH

Bennett Lee's picture

I'm trying to set a global path to give a specific Perl version priority.  I tried setting PATH in both /etc/profile and /etc/environment, but it never took.  I tracked the problem down to /root/.bashrc, line 102, which sets PATH to a fixed

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

I hate to question the TurnKey developers, but is that a bug to ignore the global PATH and reset it to basically the same as /etc/environment (minus tail :/usr/games)?  Kinda defeats the purpose of a global path if I also have to add it to every profile.

Jeremy's picture

Sounds like a reasonable point to me

But I'm not really qualified to comment because I don't know enough (or actually anything) on the rationale for doing what the core TKL devs did.

If you think it's a bug, then please feel free to lodge one, worst case scenario they'll mark it invalid and/or won't fix! Regardless if it's causing you problems I think that it's gotta be good that you discovered this and by posting about it, it is now at least somewhat documented.

AFAIK Alon & Liraz (TKL core devs) are deep in a development cycle so not sure when we'll next hear from them but hopefully one of them will drop in and give you some input.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)