TurnKey Linux Virtual Appliance Library

Can't access server with ftp client or mysql query browser

Hello all,

I'm trying to connect to the server for file upload using filezilla and it doesn't connect. I can't connect MySqul QUery Browser either. It seems to be having an issue with the settings I have selected.

I'm using the joomla appliance and installed it successfully. I can see the server on the network and it pings to it just fine. I can ftp using ssh but it takes me to the root directory rather than the www. Also, I can use localhost/"sitefolder"/index.htm to access the test site.

I'm very new to this and need any and all the help I need to set this up properly.

Thanks

Ok...After further reading in

Ok...After further reading in the forum I have figured out that the only option to use is sFTP for uploading files...so i have that working properly. Actually, I installed vsftp to see if it would help me log in as ftp and I still can't use it...just sftp.

My issues continue though. How can I access the specific site on my browser? The only way I have been able to do it is by going to webmin and accessing the file there. double click and it shows in the browser. There should be a simpler way...shouldn't there?

And the MySQL GUI Tools access to the server is still giving errors. What server host, username and password should I use? All this is very confusing to me since I know nothing on the subject and can't find anything online to help me figure it out.

I imagine there's some kind of setup that needs to be fixed somewhere in order to let me access the server with filezilla and mysql gui tools since all hosting companies do it.

Thanks for any answers

jc

Jeremy's picture

What is your setup?

Hi,

Where is it installed? On a VM on your local machine? On physical or virtual hardware within your LAN? On physical or virtual hardware somewhere online (ie WAN or VPN)?

Depending on that information, you may need to ensure that there are no firewalls, etc. Port forwarding may be required depending on your setup, and how you are trying to access your server.

Unless there is something blocking your server, the web page that its serving should be available by typing in the same IP address or hostname that you are using for SFTP. Webmin should also be available by typing in https://xxx.xxx.xxx.xxx:12321/ (replace xxx with IP numbers or hostname). If you are on a LAN and using a hostname, double check that the hostname exists on your local DNS (or better still just use the IP until you have connectivity issues sorted, then work on getting the hostname to work).

Hope thats some help.

Alon Swartz's picture

A couple of tips...

Accessing mysql remotely:
MySQL is bound to localhost by default. By commenting out the bind-address in the MySQL configuration, it will bind to all interfaces, and allow you to connect remotely:
sed -i "s/^bind-address/#bind-address/" /etc/mysql/my.cnf
You might also need to give the mysql root account privileges to access the database remotely.

vsftpd:
You might need to tweak the vsftpd configuration: /etc/vsftpd.conf

Accessing the site:
I don't really understand exactly what you are getting at, but browsing to http://appliance_ip (displayed in the configuration console) should display the joomla site.

I hope the above helps...

The purpose of wanting a web

The purpose of wanting a web server locally is for web development. Thinking you could create a single virtual instance of a lamp server and adding separate site folders to /var/www would be enough I was getting confused with all the different Lamp settings needed ( I was trying to set up a LAMP server separate from the appliances since i couldn't get it to work). Realizing it needed further virtualization inside the lamp in order to get what I wanted I figured I'd stick with the appliance which makes it much easier.

So getting to your questions,

Where is it installed? On a VM on your local machine?  On physical or virtual hardware within your LAN?  On physical or virtual hardware somewhere online (ie WAN or VPN)?

I have setup a Vbox image hosted in XP. It's using my router to connect with the applied static address. The firewall is clearing the ip address by manual insertion. I'm currently able to connect via Filezilla and my browser to the Joomla appliance using all the default settings plust the password I specified. But I can't connect to the separate iteration of the LAMP appliance (either both on or with joomla appliance off).

I still can't connect to the Joomla appliance using MySQL GUI Tools, specifically MySQL Query Browser. The reason I need this if because a tutorial is using it (althout they have theirs setup using a XAMP server). If I can't get it to work I will more than likely try to follow using phpMyadmin. But stubborn as I am, I like to see if I can find a solution for any future situations.

Here's a link to the error message I get from MySQL Query Browser. From previous reading I'm thinking I need to make the specific port available or something of that nature. You will probably let me know.

You might also need to give the mysql  root account privileges to access the database remotely.

Could you go into further details on how to do this so I can try it and see if that works? I figure, as stated before, that it could be the port not being available, but maybe this would help also.

I don't really understand exactly what you are getting at, but browsing to http://appliance_ip (displayed in the configuration console)  should display the joomla site.

You're absolutely right. It does work and it did originally. I was just confused with the fact that the appliance is self contained and doesn't have any virtualization set up within. I figure I can virtualize the LAMP server but why bother. All I have to do is create a Vbox image for every site I work on and that should be just fine if not even easier. The only one I can't access via the browser is my LAMP Vbox image even when the joomla image is turned off. I'm guessing because it's using the same ports to communicate, but once again, I'm sure you'll get me cleared on that one.

I'll continue to play around with this while I wait for any of your very helpul replies and if I figure something out I will let you know.

Thanks a bunch.

jc

Hey Alon, I found a similar

Hey Alon,

I found a similar situation in another post and I'm thinking it could help in my situation with mysql gui tools. Could you tell me what you meant by your last statement? Should I not apply the same changes as the OP did?

Thanks

jc

PS..what can I say, couldn't wait for your answer. Didn't work.

So I did: sed -i

So I did:

sed -i "s/^bind-address/#bind-address/" /etc/mysql/my.cnf

Replace "address" with my ipaddress

 

You might also need to give the mysql root

account privileges to access the database remotely.

And still no dice.

jc

PS.. This time I did it exactly how you stated the command and it worked!!!!! Now I will definitely wait for your response on the LAMP situtation.

Thanks again. You guys are great!!!

Alon Swartz's picture

Sorry, but I'm a little confused...

Could you explain what you mean by the "lamp situation".
Also, from your last post I assume that you can now access mysql remotely, correct?

Hey Alon, Yes, you assume

Hey Alon,

Yes, you assume correctly. On my virtual joomla installation using Vbox I have everything running smoothly right now (that is, without having gone in to learn the actual inner workings of joomla).

The LAMP situation is with respect to a separate virtuall installation I have created inside Vbox using your LAMP appliance. I have installed the LAMP appliance and have set the static ip different from the joomla appliance installation. If I run the LAMP installation alone or along side the joomla install, I can't access the LAMP install in any way from the sftp or browser.

I'm wondering if it has anything to do with the fact that they use the same port for webmin. But the fact remains that I can't access any aspect of this server.

Did I explain myself properly?

jc

Alon Swartz's picture

Bridged networking?

Lets simplify. You can't access the LAMP server over the network, period.

This leads to me to question your VM networking configuration. I am reminded of your previous post where you needed to configure bridged networking for your Joomla VM. Did you do the same for LAMP?

Hey Alon, If I'm not

Hey Alon,

Yes. Your statement is correct. As far as the network setting, if I'm not mistaken, I did since I set them up at the same time. However, I'm not near that system right now so I will check later on tonight.

Am wondering. What would I need to do to get them both running at the same time as if I had different servers running? Right now they both use "ipaddress:12321" and "ipaddress:12322" for webmin and mysql. I'm thinking there are other similarities that may conflict also or is the speific por reffering to the server and not my XP machine.

I just want to be able to run any Vbox server I want or create alongside any other Vbox server at the same time if needed. Not have to turn one on and the other off. Have I explained myself properly?

Thanks Alon

jc

Yes, Alon. It turned out to

Yes, Alon. It turned out to be the network setting. It's back to bridged and running great. I'm going to test running them both at the same time to see what happenbs.

jc

FTP how to

Hi, Sorry to drag up an old thread, but I thought it would be better than waste a new one, when the questions already been asked. I'm trying to figure out how to ftp my html files to the /var/www folder...

I am running the Lamp Server in a VMbox, on a winxp machine. No problems at all. I have the networking setup as a bridged static IP (on the vmbox) which makes the Lamp seem as a whole different PC (192.168.1.15)...I use nat holes for the webadmin, mysql, and other utilities. I also have a no-ip.com static address and an IP passthrough on my router that takes me directly to my webcontent (in /vars/www), remotely.

Now for the FTP Part, when I try to connect using fireftp or filezilla, I am using the no-ip.com (or my web ip) address as my host (user: root)(pass: mypassword) but cannot connect. Am I not doing this correctly?  

 

 

Jeremy's picture

SFTP uses port 22

so you'll need to make sure you are forwarding that port through NAT. Also make sure you use SFTP in the drop down in Filezilla (rather than the standard FTP - even if you use port 22 it still won't work). I'm not familar with FireFTP but assuming it can handle SFTP then its just a matter of finding the option to enable it.

Thank Ya!

Jedmeister, Thank You. My first ever server...lots of new things to pick up on..like 'sftp' (I presume the s is for 'secure'). Forwarded the port and used the sftp setting in the clients...works now..again much thanks.

Jeremy's picture

Glad you got it sorted

Yes the 'S' is for secure. Forwarding port 22 is also handy for SSH. IMO PuTTY is a good Windows app.

Same problem with FTP

I've got Turnkey Torrent Server. It's on an old hw, not VM.

& I can't access to ftp. 

vsftp is installed & running & listening:

root@torrentserver:~# ps -ae

....

4100 ? 00:00:00 vsftpd

___________________________________________________

When I'm trying to connect with localhost, it's ok. It works.

But when I'm trying to connect with the local interface IP, it doesn't work.

But the local interface is up and is pinging successfully.

root@torrentserver:~# ftp localhost   

 

Connected to localhost.
220 (vsFTPd 2.0.6)
 
Name (localhost:root): 
331 Please specify the password.
Password:
 
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
 
ftp> exit
221 Goodbye.
root@torrentserver:~# ftp 192.168.1.10
ftp: connect: Connection refused
 
ftp> 

May be it's an internal server firewall?

Or something else? 

Jeremy's picture

As stated above you need to use SFTP not FTP

SFTP uses SHH and thus port 22 (rather than port 20). TKL appliances will not accept remote FTP connections!

I use a GUI client (Filezilla) and have no experience using SFTP via commandline but a quick google suggests that this should work:

sftp 192.168.1.10

SFTP is slow

It's pity that only sftp.

So the appliance is useless for me(.

By sftp & 100mb link I've got only 1MBps transfer speed (for reading). I use filezilla.

It's not enough for a home films storage.

I think I should use HDD internaly in my win PC instead =(. For the films storage.

Or may be some more workaround with turnkey?

Jeremy's picture

Not sure why you're having that problem?

On my home network I get much faster than that (using Filezilla under Win XP or Ubuntu). I just did a quick check then (WinXP upload to TKL via Filezilla using SFTP) and it was jumping around a fair bit but I was getting ~8MB/s (~64mbps - see below). My first suspicion would be flakey support for your NIC under Linux, although I'm only guessing. It could be caused by a myriad of things. For example when I had a capacitor on the way out in my home router (a cheap old consumer grade job) it would often transfer large files very slowly across the LAN. If its a driver thing, there may be a workaround, or it may be better under Lucid (so when the next TKL release comes out). I guess one thing to consider too, if it's old hardware, perhaps it only has a 10mb NIC?

It may be worth double checking that you are comparing apples to apples. Often Network speeds are noted in Mbps (Mega bits per second) whereas from memory Filezilla reports speed as MB/s (Mega Bytes per second). They are not the same (although you should still be getting more than 1MB/s transfer speed - 1MB/s is closer to 10mbps than 100mbps)

Besides why use FTP in a home fileserver environment? Why not use the TKL Fileserver appliance and use Samba to share files (ie Windows Network Fileshares)? On my home network it works very nicely.

Solved

So, I tried to connect directly too PCs, Turnkey Linux& Windows Workstation with 1Gbps NIC each.

& I've got almost 2MBps =)

I think it's because my Tunrkey is on an old HW. About 100MB OM, P II 400Mhz. For SFTP some more performance needed =-))

That's why I simply put the HDD into my Win WS and now completely happy =)

TY 4 replies.

Jeremy's picture

Yeah perhaps that hardware is whats being slow

400Mhz is pretty slow CPU so perhaps thats the problem. You could probably enable FTP (security risk, but irrelevant if only using on LAN), but it sounds like you solved your issue anyway.

turnkey file server

sory i am probably not posting where i should. but can u help me? how can i access mi file server online from another location not included in the same lan. both locations have internet conection

Jeremy's picture

I can't give you exact steps

Because there are to many unknowns, but basically you will need a static IP or a dynamic DNS updater (you can use the Hub for this if you like). And you will also need to forward the port(s) (if behind a NAT router/modem and/or add an exception (if behind a hardware firewall).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)