TurnKey Linux Virtual Appliance Library

Zimbra appliance not sending emails

Hi,

I am experimenting with the Zimbra appliance at home as a prelude to deploying it on the Cloud for future corporate use (small company, less than 20 employees). I have successfully installed the ISO image under VMWare Server running on a Windows Home Server machine on my home network. I can log in successfully for email and administration, and have successfully used the Zimbra Desktop to connect to my email account. I have not directed any domain traffic at the server yet, and when I do so this will be via DynDNS for now. So far so good.

My problem is that while I do not expect to be able to receive email to <anything>@example.com, I was hoping that I would be able to send an email to my home email address. When I compose and send the email, everything works as expected with the Zimbra Desktop client, however the email does not materialise in my home email account. Is this something I should expect, or is there a way for me to successfully send an email with my current setup. I would like if possible to get this working before making the next small step with DynDNS.

Thank you in advance for looking at this.

Best regards,     Simon

Jeremy's picture

You can't use example.com

See this post here. Also there is a link and some other useful info on the Appliance page.

Hopefully that will sort it.

Thank you for the prompt reply

To make sure that I would have a clean system, I deleted the virtual machine and created a new one from scratch. I then used zimbra-conf straight after installation.

This gave me a system that had no references to example.com, rather it only references mydomain.com. I created a user (simon @ mydomain.com) and sent an email to my home email address (simon @ myhomedomain.com). When I pressed send, I get a "Networking Service Error" with details as below.

Thank you for your attention on this issue.

Best regards,       Simon 


method:        SendMsgRequest
msg:                system failure: MessagingException
code:              service.FAILURE
detail:             soap.Receiver
trace:              btpool0-15.1265558902843:359A652C8539c29
request:        Body: {
           SendMsgRequest: {
                _jsns: “urnzimbraMail”,
                m: {
                     e: [
                           0: {
                                a: “simon @ myhomedomain.com”,
                                add: 1,
                                t: “t”
                            },
                           1: {
                                a: “simon @ mydomain.com”,
                                p: “Simon Ziegler”,
                                t: “f”
                            }
                      ],
                     idnt: “a5c9979b-f3ec-49df-afbd-8b9c4806aa9c”,
                     mp: [
                           0: {
                                content: {
                                     _content: “”
                                 },
                                ct: “text/plain”
                            }
                      ],
                     su: {
                          _content: “test”
                      }
                 },
                suid: 1265558900044
            }
         },
        Header: {
           context: {
                _jsns: “urn:zimbra”,
                account: {
                     _context: “simon @ mydomain.com”,
                     by: “name”
                 },
                authToken: “(removed)”,
                format: {
                     type: “js”
                 },
                sessionId: {
                     _content: 12,
                     id: 12
                 },
                userAgent: {
                     name: “ZimbraWebClient – [unknown] (Win)”,
                     version: “5.0.18_GA_3011.UBUNT8”
                 }
            }
         }

 


No errors now, but no emails sent either

Hi,

I restarted the server and the errors above have now gone. I now have a nearly working server that does not use the example.com domain, but instead uses a spare domain that I own. The problem is that emails sent to my home email address (hosted by Gmail) still do not come through.

As a recap, this server is running under VMWare Server on a Windows Home Server box on my home network. The internet settings for the domain name that I am testing on do not point to this server.

Any ideas?

Thanks,      Simon


Jeremy's picture

You are not the first to find this appliance frustrating!

Hopefully the next revision (based on Ubuntu 10.04 & Zimbra 6) will be a little easier and friendlier to setup.

Out of interest did you follow the link on the appliance page?

Note: Prior to executing zimbra-conf, please refer to this thread for a bugfix. The thread also includes details on how to specify a custom hostname (other than mail).

If you've already done that, or for some reason it doesn't apply (which it may not as it doesn't seem like you are getting the same error) then the only other thing I can suggest off the top of my head is network connectivity.

Has your VM got 'Bridged' networking enabled? If not then try that.

Does your WHS have some sort of firewall enabled? If so you will need to allow an exception for VMware Server.

From inside your TKL Zimbra try to ping www.google.com to ensure your DNS is working and the network is clear. If that fails, then run a traceroute ("traceroute www.google.com") to give you a lead to where it is failing (if you are not getting a DNS connection then traceroute will fail too, even if the network pathway is clear).

Another possibility that just occurred to me (thinking out loud!) is that your ISP is blocking the outgoing port that Zimbra uses by default. I know many ISPs block the standard outgoing port(s) for email (to minimise spam from Win zombies). The standard outgoing port for email clients is 25 but I'm not sure if Zimbra uses that port to send or not.

I'll work on this

Thank you. First, I forgot the bugfix (doh!), so I will work on that and then will work through your other points. I'll report back when I've managed to wrap my mind around what to do: this may take a while!

Cheerio,    Simon


Done this, but still to no avail

Hi,

I applied the bugfix and re-ran zimbra-conf. I also successfully pinged www.google.com. I then checked your port blocking thoughts, and it seems (see here) that my ISP blocks port 25 for dynamic IP addresses - I have this. Looks like I need to bite the cost bullet and pay for a static IP address. This will do me good anyway

 

In the meantime, thanks again for your time on this, and I will update progress, with a proper signoff when I know the final situation.

Until later,     Simon


Jeremy's picture

Another possibility is to use an alternative port

I'm not quite sure how you do that but I'm sure the Zimbra documentation should tell you how. That may save you from spending extra on a static IP.

Good luck

Everything now works

Hi,

I just managed to cut over to my ISP's static IP product (I really needed to get this anyway) which also unblocks port 25. This has fixed the problem and I can now send emails. Thank you so much for your quick and accurate help! This problem is now fully resolved.

Best regards,      Simon

 

For others in my situation, here is a recap on how to get the Zimbra Appliance working with your domain name. Take these steps in order.

  • Install the appliance and then log in for the first time.
  • Make sure that you run the zimbra-conf bugfix (I made a mistake here and had to start again) before doing anything else.
  • Run zimbra-conf.
  • Do a shutdown and restart on the appliance.
  • If you find that emails are not being delivered, make sure that your ISP does not block port 25.

 


For anyone else in the

For anyone else in the position of having port 25 blocked, in the Admin UI you can set an external SMTP Relay (usually your ISP or a service from companies such as DynDNS etc.) for your outgoing mail and if that needs authentication you should follow this wiki article: http://wiki.zimbra.com/index.php?title=Outgoing_SMTP_Authentication

Regards

 

Bill

Jeremy's picture

My pleasure! Glad you got it sorted.

Also thanks for letting us know how you went.

The answer to your question

The answer to your question depends on whether you are behind a NAT router or Firewall, if the answer is 'yes' then you need a Split DNS set-up. Zimbra (well, actually Postfix) requires DNS A & MX records to be able to do a DNS lookup for the Zimbra server so it can deliver the mail. So are you behind a NAT router or not?

Regards

 

Bill

Your external DNS records

Your external DNS records should be exactly the same as your internal ones in the sense that you need an A record pointing to the public IP address and the MX record with your domain name and FQDN for your server, the internal records point to the LAN IP and have the FQDN of the Zimbra appliance. The set-up for the internal DNS is described quite well in the article on Split DNS I post the link for in an earlier post above. You can also check the config by looking at the 'Verify....' section of that article.

 

You will also need to correct ports forwarded through your NAT router to the Appliance once you've configured it on a fixed IP address.

Regards

 

Bill

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)