Rick's picture


Hello all and thank you very much for taking the time to have a look at my issue here.
Let me preface this post by saying that I am VERY new to the Linux world and this Joomla Appliance is my first real set of experiences with Linux and MySQL. I come from a MS totalitarian background and environment, but I am trying to learn as fast as possible. So please keep that in mind if you are kind enough to offer up suggestions for resolution. Feel free to skip down to the “What’s happening” and “My Goal” section if you are not interested in the back story.
My Situation/Back Story:
I have built a little Joomla site that is quite simple and only using a few extra plug-ins/modules, using the Turnkey Joomla 1.5 appliance on a Sun VRBox host running on WinXP SP3. This has been running AWESOME and with no problems that I couldn’t overcome.  However, before I could put a solid backup process in place (was in the process of reviewing how) I put the physical server in a enclosure and ran a thermostatically controlled external fan off the primary PROC fan’s leads, to vent the enclosure. When I did this, I did not realize the proc fan was not linearly controlled, and so from time to time when the exterior fan would kick on (100% no matter what) it would do something odd to the power supply and flat out bounce the host and naturally everything running on it including the SunVM/Joomla VMBox. Very surprisingly it booted right back up without a single problem (expecting a XP issue, not really worried too much about my Static Joomla Box) after which I quickly stopped write caching to stave off damage upon a reoccurrence. I did order a fan controller that day, however it ran on. Before my controller came, it did this quite a few more time, and finally, my Joomla Appliance VM dumped and now will no longer boot what so ever.
What’s Happening:
Every time upon boot attempt the Joomla Appliance now directly after the “Loading, please wait…” prompt comes back with “run-init: /sbin/init: Accessing a corrupted shared library [ 23.111886] Kernel Panic – not syncing: Attempted to kill init!”. It then just stays there until I kill it, which while in that state it eats 100% of the CPU
What I have done:
After searching the error and seeing many other flavors of Linux that show the same thing as well as the hunch that the file system went awry thanks to the crashes, I downloaded a Ubuntu live iso so I could console and run fsck on the volume. That ran OK and after forcing it to run checks (volume kept coming back as Clean) it found a few chunks and supposedly fixed them, however no joy. I tried getting into the grub and booting the recovery arc but that does exactly the same Kernel Panic error and gets me nowhere either. I’ve tried quite a few other things including the ACPI tricks but nothing worked so far. 
My Goal (Please Help):
So I do have some time invested into the actual content and making of the site and I really need to get it back. I really need to either fix the in place OS (which is proving to be very difficult with my limited Linux based skill set) or move the entire Joomla/MySql Contents from the one VMDK to a new one (I already built a new blank shell in hopeful anticipation of this). The entire file system still is very much intact and subsequent checks run fine.  I can navigate through the filesystem fine and read everything I have tried so far with no problems. Can anyone please give me some direction with this? 
Neil Aggarwal's picture

I assume you have not kept regular backups. That would be ideal.  Consider setting that up when you get everything working.

I dont think it is worth the effort to revive the old box.  Since you can access your files, copy over the web files and database to a new appliance.  For the database, you can copy all the database files over.  Take a look at this article:



Add new comment