Adam's picture

I've had moodle running on a VM for a couple of weeks now.

Today, I did an apt-get upgrade from the web shell (I've since tried it from Webmin and SSH'd into the server as well). There were three packags to upgrade, one of which was moodle. The other two worked fine. The moodle upgade failed with the following

Setting up moodle (1.8.2-1ubuntu4.3) ...
* Reloading web server config apache2 [ OK ]
Failed to connect to database: Access denied for user 'root'@'localhost' (using password: NO) at -e line 5, <> line 1.
Failed to create database (incorrect admin username/password?)
It's also possible that mysql-server wasn't running. After install
is completed, you will need to make sure mysql-server is running
and that you supplied correct information. Try:
sudo dpkg-reconfigure moodle
cp: cannot create regular file `/var/lib/update-notifier/user.d/moodle-reconfigure-required': No such file or directory
dpkg: error processing moodle (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

The installed version seem to be running fine. It just won't upgrade.

Just for grins (and because we are not in production with this yet), I tried changing the password for root@localhost to what I already knew it to be via phpMyAdmin. Everything still runs fine, even after reboot but the upgrade still fails.

Any ideas on this one?


Add new comment