hoschi's picture


I want to install an apache2 in my tklpatch. How can I stop apache2 in the lucid beta appliance? I use this appliance to apply a patch to the same iso.

I tried "/etc/init.d/apache2 stop" but the file doesn't exist!

Jeremy Davis's picture

A number of services are now handled by upstart in Ubuntu (such as SSH, Apache, MySQL and others). I'm not sure but I reckon that's the problem.

I haven't tested myself but try

service apache stop 


initctl stop apache

I'm not sure how you actually disable services though (they should spawn again after a restart with the above commands) although that may not be relevant to your current needs. I also came across an article here which I have only skimmed but looked like it could be useful if you want some more info.

Liraz Siri's picture

Upstart does things a bit differently, but it's actually not harder, just different.
# start, stop, status are all symlinks to initctl

stop myservice
start myservice
status myservice

man initctl
Jeremy Davis's picture

Always better to have a fully informed solution, than a semi-informed jab in the dark! :)

Add new comment