Don Moody's picture

I made the mistake of trying to create my own self-signed certificates with webmin and now I am going around in circles sometimes and can login and work and other times I am redirected back to the "unsecure certificate page" with the error; uses an invalid security certificate.

The certificate is only valid for the following names: ,  

(Error code: ssl_error_bad_cert_domain)


I keep going in damned circles. I read that the appliance will regenerate it's certificates upon reboot so I tried that. Next I tried deleting the CA certificate and rebooting still no success. This has been going on for over 6 hours.

The thing that really sucks is that an iPhone I have can always login and has had no issues.

Can anyone give me a pointer on how to reset the certificates and CA? CLI or webmin I don't care.

Don Moody's picture

I get this message;

The site you are looking for is currently not available.

What is it's a free dynamic DNS (DynDNS) service provided by the TurnKey Hub. It includes a simple to use web interface as well as a powerful API.

Don Moody's picture

Does anyone know which init script set the ssl certificates up when I first booted my appliance? Rebooting does not seem to solve the issue even though as I understand the certificates should be regenerated.

I must have messed up the server CA and I don't know how to reset it.

I've run out of ideas.

Cleared out ALL of the certificates in my browser. I'm very tempted to remove all of the CA certificates for Turnkey too.

I'd just by a certificate but I'll be moving the site to it's domain soon and then I'll have to buy another certificate.

Don Moody's picture

##root@joomla25 inithooks/firstboot.d# ./15regen-sslcert

Jeremy Davis's picture

Try this:

cd /usr/lib/inithooks/firstboot.d/

Don Moody's picture

That is correct. I typed it in earlier and it did actually work out for me. Thank you for the confirmation.

Don Moody's picture

Interesting, I never even noticed anything missing before.

In my Amazon EC2 terminal I have a space instead of a hashtag or ampersand. So, it would actually be my  EC2 Joomla 2.5 on Debian 6  appliance bash window that is hiding some of the folders. It is not the whole path that I see in my bash terminal window.

For me it's good to know though because I may do a support video or post a screen shot in a forum posting for a client, or, here.

I'm guessing I need to have a look at the ~/etc/.bashrc and ~/etc/bash_config as well as the ~/etc/.profile files to see if I can learn anything about how to change it.

Just thinking out loud and from memory so to speak.

Add new comment