Koluskomtu's picture

Hi all.


I'm confused about logging in to Webmin. After, I registered a domain of my own. After

the 48 hour grace period the domain worked and "I think" I got the a record configured 

however I am a bit of a noob with understanding CNAME alias and round robin. 


Anyhoo, after the  domain appeared to work the webmin fails every time I try to

load it with an elastic IP and the old IP. Same with the new domain name. What do I

need to do. I can't make a public key because I can't get in. I tried pasting by Private key

I created and it is a no go. Is it a Firewall issue? Do I remove webmin since it has address

and add the IP for my router?





Jeremy Davis's picture

What exactly does it do? Does it just not load? Does it give some error?

It should load with either the FQDN or the public IP eg https://<FQDN-or-public-IP>:12321

If it is refusing to load using either of these then perhaps your browser is getting upset with the certificate? I recall something similar happening to me a while ago and IIRC I had to remove the self-signed certificate that I had already allowed. Perhaps you could just try a different web browser to see if that's the issue.

Koluskomtu's picture

Hi Thanks for replying.


I tried numerous options. I retraced my steps and realized

I had changed my firewall settings when I set up wireless on my new DSL connection. This
was while I had already signup with Amazon and the Turnkey Hub. I lowered the security
and logged right in with no problem. 
I'll have to read up on properly configuring certificates. My small micro instance
has no SSH key pair or public key and I'm searching for where to enter it in the hub.
Maybe, if I create a new instance and migrate the content it will teach me a few things.
I should also remember to get certificate when asked to when I initially login. I added 509 certificates
from amazon to my browser but it is still listed as untrusted. Silliness. Saying I have to register with
an authority. 
Thanks for the FQDN heads up. I don't understand what that is. Will research.
Jeremy Davis's picture

Web browsers are configured to only allow certificates signed by specific authorities. So if you don't want the warnings then you'll need to pay one of those authorities (or a registered agent) to get one. AFAIK there is no legitimate way around that.

As for FQDN - it's Fully Qualified Domain Name eg www.turkeylinux.org (generally has the 3 separate parts)

Add new comment