chestwood96's picture

Hy guys im kinda new to linux but im trying to get into it

i tryed to setup a little home/torrent server whit turnkey but i ran into a problem whit the lancard of the pc im using for it if i want to activate eth0 it says siocsifflags file not found error ifconfig just gives me some local loopback somebody knows how to solve that? the lan card is an onboard Intel(R) 8255xER

thanks for any constructive coment



im swiss so sorry for my poor english

Jeremy Davis's picture

And it seems that most others with this same error relates to drivers. But having a quick look on a Debian HCL (Hardware Compatability List) I found - it seems that the Intel chip you have should be supported since 2.6.25 (Debian 6/TKL v12.x has 2.6.32). To back that up all the results I found that related to issues with this NIC with Linux kernel, all relate to ~2007-2009. So theoretically it should just work...

Obviously that's not the case though...

From my reading (here and here) it seems that this hardware should  use the e100 firmware (or perhaps the ee100pro - not sure why it gets 2 mentions on the Debian Wiki).

So like the second link above suggests you could check your dmesg log to see what is happening 'dmesg |grep e100'.

chestwood96's picture

i got it working by just coppying a downloaded e100 folder into /lib/firmware now it works but how does the torrent thing work i get into webmin but the torrent part on port 12322 doesnt work

Jeremy Davis's picture

But I thought that it was just via the (normal http) port 80? Perhaps not. Glad you got the driver issue sorted though, but as I said, from what I gather it never should have been an issue. Perhaps your download was slightly corrupted?

Add new comment