Ryan's picture

I have deployed a Redmine applinace and started using it a bit.  Have not added any mods and have not done anything to it other than add a theme, create a project, and add some content.

Backing up the appliance works fine, no errors and it shows up in the hub.  However when I go to restore the appliance, I get the following error:

Any ideas?

> tklbam-restore 57 --noninteractive
Restoring duplicity archive from s3://s3.amazonaws.com/tklbam-........ 
Traceback (most recent call last): 
File "/usr/bin/tklbam-restore", line 385, in <module> 
File "/usr/bin/tklbam-restore", line 343, in main 
opt_limits, opt_time, credentials=credentials, rollback=not no_rollback) 
File "/usr/lib/tklbam/restore.py", line 104, in __init__ 
backup_archive = self._duplicity_restore(address, cache_size, cache_dir, credentials, secret, time) 
File "/usr/lib/tklbam/restore.py", line 82, in _duplicity_restore 
File "/usr/lib/tklbam/squid.py", line 59, in start 
raise Error("%s failed to start\n" % SQUID_BIN + self.command.output) 
squid.Error: /usr/lib/tklbam/deps/usr/sbin/tklbam-squid failed to start 
Detected 32-bit system, limiting maximum_object_size to 2000 MB 
2012/11/04 02:40:35| Creating Swap Directories 

Jeremy Davis's picture

And I have no idea why you would have an error like this trying to restore your server. Have you tried restoring to a clean server? Perhaps test in a VM.

Ryan's picture

Hi Jeremy, Thanks for the quick reply.

Yes, the restore I am doing is from a clean install (unless I do not understand the process, which could be completely possible..?)  -- I deploy a new Redmine appliance in Proxmox (thank you for the feedback on PVE by the way from another post I created).  I use the same template I used to create the original RM appliance.  After it's online, I do a restore, chosing the backup from the first RM appliance.  This is when I get the error.

Am I following the right process?  


The other thing I did was to delete the backup from the hub and re-run the backup, then try restroing that backup per my process noted above, however I get the same result.  

Ryan's picture

I was also working on a Twiki appliance over this weekend, and I just tested the same backup and restore process and I'm getting the same error.  

The thing that is the same is my PVE (Proxmox) server I am using.  I will try it on another Proxmox server, but it's worth noting that I have (2) PVE nodes joined to a single PVE cluster -- unsure if the cluster aspect of PVE could be causing this issues.

UPDATE II --  I've tested the same process on my second PVE node, and on there the restore is successful.  So it has something to do with my first PVE node, I believe.

Add new comment